# CVE-2024-46544: Apache Tomcat Connectors: mod_jk: local users can view and modify configuration

> Local users can view and modify mod_jk shared memory configuration, leading to information disclosure or denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2024
- **Updated:** 31 Oct 2024
- **Also known as:** ALSA-2024:7457, CLSA-2026-1779204030, DEBIAN-CVE-2024-46544, DLA-3919-1, GHSA-2582-53pq-96cq, MGASA-2024-0315, RHSA-2024:7457, RHSA-2024:8928, RHSA-2024:8929, RLSA-2024:7457, SUSE-SU-2025:0143-1, UBUNTU-CVE-2024-46544, USN-8369-1

## What is CVE-2024-46544?

CVE-2024-46544 is a medium-severity vulnerability in Debian Debian Linux, published on 23 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incorrect Default Permissions vulnerability in Apache Tomcat Connectors allows local users to view and modify shared memory containing mod_jk configuration which may lead to information disclosure and/or denial of service.

This issue affects Apache Tomcat Connectors: from 1.2.9-beta through 1.2.49. Only mod_jk on Unix like systems is affected. Neither the ISAPI redirector nor mod_jk on Windows is affected.

Users are recommended to upgrade to version 1.2.50, which fixes the issue.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2024-46544?

It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mod_jk` | AlmaLinux:9 | All versions | 1.2.50-1.el9_4.1 |
| `mod_jk` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.2.50-1.el9_4.1 |
| `mod_jk-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.2.50-1.el9_4.1 |
| `mod_jk-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.2.50-1.el9_4.1 |
| `mod_jk` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:1.2.50-1.el9_0.1 |
| `mod_jk-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:1.2.50-1.el9_0.1 |
| `mod_jk-debugsource` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:1.2.50-1.el9_0.1 |
| `mod_jk` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.2.50-1.el9_2.1 |
| `mod_jk-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.2.50-1.el9_2.1 |
| `mod_jk-debugsource` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.2.50-1.el9_2.1 |
| `mod_jk` | Rocky Linux:9 | All versions | 0:1.2.50-1.el9_4.1 |
| `apache2-mod_jk` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.2.50-7.12.1 |

Products: Apache Tomcat Connectors, Debian Debian Linux.

## How do I fix CVE-2024-46544?

Upgrade to a fixed version.

## Is CVE-2024-46544 being exploited?

There is no known exploitation of CVE-2024-46544 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2023-41081](https://insights.sbomify.com/CVE-2023-41081/): Apache Tomcat Connectors: Unexpected use of first declared worker in mod_jk for unmapped request (high 7.5)
- [CVE-2014-8111](https://insights.sbomify.com/CVE-2014-8111/): Missing authorization in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46544 and fix it if it is affected.

What it is: CVE-2024-46544 is a medium-severity vulnerability in Debian Debian Linux, published on 23 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-46544 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46544/ (Markdown: https://insights.sbomify.com/CVE-2024-46544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46544
- OSV: https://osv.dev/vulnerability/CVE-2024-46544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46544/
Summaries are generated and may contain mistakes; the official description above is the record.
