{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-46613 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-46613 is a medium-severity vulnerability in n/a, published on 10 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-46613 and fix it if it is affected.\n\nWhat it is: CVE-2024-46613 is a medium-severity vulnerability in n/a, published on 10 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-46613 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-46613/ (Markdown: https://insights.sbomify.com/CVE-2024-46613/index.md)","id":"CVE-2024-46613","markdown":"https://insights.sbomify.com/CVE-2024-46613/index.md","name":"CVE-2024-46613","record":{"aliases":["DEBIAN-CVE-2024-46613","GHSA-q743-h9vw-38hv","UBUNTU-CVE-2024-46613","openSUSE-SU-2025:14734-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"WeeChat IRC client","requires_auth":"none","summary":"An integer overflow in WeeChat can lead to a buffer overflow, potentially allowing code execution or denial of service.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"weechat","vendor":"weechat"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"WeeChat before 4.4.2 has an integer overflow and resultant buffer overflow at core/core-string.c when there are more than two billion items in a list. This affects string_free_split_shared , string_free_split, string_free_split_command, and string_free_split_tags.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2024-46613","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2024"},"n_packages":1,"n_references":2,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2024-46622"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.5.1-1.1"],"introduced":["0"],"last_affected":[],"package":"weechat","purl":"pkg:rpm/opensuse/weechat\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14734-1"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2024-46612"},"products":["n/a"],"published":"2024-11-10","related":[{"cvss_score":4.3,"headline":"Security feature bypass in n/a","id":"CVE-2022-28352","kev_date_added":null,"published":"2022-04-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-19","vendors":["n/a"]},"summary":"An integer overflow in WeeChat can lead to a buffer overflow, potentially allowing code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2024-46613/"}