CVE-2024-46901 Apache Subversion: mod_dav_svn denial-of-service via control characters in paths
Authenticated users with commit access can cause repository disruption by committing corrupted revisions via mod_dav_svn.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-46901?
CVE-2024-46901 is a low-severity denial of service vulnerability in Debian Debian Linux, published on 9 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Insufficient validation of filenames against control characters in Apache Subversion repositories served via mod_dav_svn allows authenticated users with commit access to commit a corrupted revision, leading to disruption for users of the repository.
All versions of Subversion up to and including Subversion 1.14.4 are affected if serving repositories via mod_dav_svn. Users are recommended to upgrade to version 1.14.5, which fixes this issue.
Repositories served via other access methods are not affected.
Which versions are affected by CVE-2024-46901?
1 open source package ship an affected version, including subversion. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
subversion Bitnami | All versions | 1.14.5 |
Linux distribution packages (10)
subversion SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 1.14.1-150400.5.3.1 |
subversion SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 1.14.1-150400.5.3.1 |
subversion SUSE:Linux Enterprise Module for Development Tools 15 SP5 | All versions | 1.14.1-150400.5.3.1 |
subversion SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 1.14.1-150400.5.3.1 |
subversion SUSE:Linux Enterprise Module for Server Applications 15 SP5 | All versions | 1.14.1-150400.5.3.1 |
subversion SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 1.14.1-150400.5.3.1 |
subversion SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.10.6-3.9.1 |
subversion openSUSE:Leap 15.5 | All versions | 1.14.1-150400.5.3.1 |
subversion openSUSE:Leap 15.6 | All versions | 1.14.1-150400.5.3.1 |
subversion openSUSE:Tumbleweed | All versions | 1.14.5-1.1 |
Products include Apache Subversion, Debian Debian Linux.
How do I fix CVE-2024-46901?
Upgrade subversion to 1.14.5 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-46901 being exploited?
There is no known exploitation of CVE-2024-46901 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
- CVE-2017-9800 A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha
- CVE-2013-4246 Denial of service in n/a
- CVE-2015-5259 Integer overflow in n/a
- CVE-2024-45720 Apache Subversion: Command line argument injection on Windows platforms
- CVE-2015-0202 Denial of service in n/a
Sources
Also known as ALPINE-CVE-2024-46901, AZL-54056, AZL-54063, BELL-CVE-2024-46901, BIT-subversion-2024-46901, CLSA-2025-1754649017 and 21 more.