# CVE-2024-46901: Apache Subversion: mod_dav_svn denial-of-service via control characters in paths

> Authenticated users with commit access can cause repository disruption by committing corrupted revisions via mod_dav_svn.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2024
- **Updated:** 13 Apr 2025
- **Also known as:** ALPINE-CVE-2024-46901, AZL-54056, AZL-54063, BELL-CVE-2024-46901, BIT-subversion-2024-46901, CLSA-2025-1754649017, CLSA-2025-1754649298, CLSA-2025-1754940263, CLSA-2025-1754940449, CLSA-2025-1754941300, CLSA-2025-1755004868, CLSA-2025-1755074254, CLSA-2025-1756408610, CLSA-2025-1756409018, CLSA-2025-1756489732, CLSA-2026-1778495013, DEBIAN-CVE-2024-46901, DLA-4127-1, GHSA-53gr-8h72-9w7p, MGASA-2025-0058, OESA-2024-2538, SUSE-SU-2024:4366-1, SUSE-SU-2025:0871-1, UBUNTU-CVE-2024-46901, USN-7818-1, USN-7818-2, openSUSE-SU-2024:14570-1

## What is CVE-2024-46901?

CVE-2024-46901 is a low-severity denial of service vulnerability in Debian Debian Linux, published on 9 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insufficient validation of filenames against control characters in Apache Subversion repositories served via mod_dav_svn allows authenticated users with commit access to commit a corrupted revision, leading to disruption for users of the repository.

All versions of Subversion up to and including Subversion 1.14.4 are affected if serving repositories via mod_dav_svn. Users are recommended to upgrade to version 1.14.5, which fixes this issue.

Repositories served via other access methods are not affected.

Weakness: CWE-20 (Improper Input Validation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2024-46901?

1 open source package ship an affected version, including subversion. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `subversion` | Bitnami | All versions | 1.14.5 |
| `subversion` | SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 1.14.1-150400.5.3.1 |
| `subversion` | SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 1.14.1-150400.5.3.1 |
| `subversion` | SUSE:Linux Enterprise Module for Development Tools 15 SP5 | All versions | 1.14.1-150400.5.3.1 |
| `subversion` | SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 1.14.1-150400.5.3.1 |
| `subversion` | SUSE:Linux Enterprise Module for Server Applications 15 SP5 | All versions | 1.14.1-150400.5.3.1 |
| `subversion` | SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 1.14.1-150400.5.3.1 |
| `subversion` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.10.6-3.9.1 |
| `subversion` | openSUSE:Leap 15.5 | All versions | 1.14.1-150400.5.3.1 |
| `subversion` | openSUSE:Leap 15.6 | All versions | 1.14.1-150400.5.3.1 |
| `subversion` | openSUSE:Tumbleweed | All versions | 1.14.5-1.1 |

Products: Apache Subversion, Debian Debian Linux.

## How do I fix CVE-2024-46901?

Upgrade subversion to 1.14.5 or later.

## Is CVE-2024-46901 being exploited?

There is no known exploitation of CVE-2024-46901 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2017-9800](https://insights.sbomify.com/CVE-2017-9800/): A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha (critical 9.8)
- [CVE-2013-4246](https://insights.sbomify.com/CVE-2013-4246/): Denial of service in n/a (high 8.8)
- [CVE-2015-5259](https://insights.sbomify.com/CVE-2015-5259/): Integer overflow in n/a (high 8.6)
- [CVE-2024-45720](https://insights.sbomify.com/CVE-2024-45720/): Apache Subversion: Command line argument injection on Windows platforms (high 8.2)
- [CVE-2015-0202](https://insights.sbomify.com/CVE-2015-0202/): Denial of service in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46901 and fix it if it is affected.

What it is: CVE-2024-46901 is a low-severity denial of service vulnerability in Debian Debian Linux, published on 9 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-46901 in the wild and no public exploit code.

Affected packages and fixed versions:
- subversion (Bitnami): affected all versions; fixed in 1.14.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46901/ (Markdown: https://insights.sbomify.com/CVE-2024-46901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46901
- OSV: https://osv.dev/vulnerability/CVE-2024-46901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46901/
Summaries are generated and may contain mistakes; the official description above is the record.
