CVE-2024-46910 Apache Atlas: An authenticated user can perform XSS and potentially impersonate another user

High 7.1 Published Updated

An authenticated user can execute cross-site scripting attacks to potentially impersonate other users in Apache Atlas.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-46910?

CVE-2024-46910 is a high-severity cross-site scripting vulnerability in Apache Atlas, published on 13 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An authenticated user can perform XSS and potentially impersonate another user.

This issue affects Apache Atlas versions 2.3.0 and earlier.

Users are recommended to upgrade to version 2.4.0, which fixes the issue.

Weakness: CWE-80

Which versions are affected by CVE-2024-46910?

2 open source packages ship an affected version, including org.apache.atlas:apache-atlas. It affects 1 product.

PackageAffectedFixed in
org.apache.atlas:apache-atlas MavenFrom 2.0.02.4.0
org.apache.atlas:apache-atlas MavenFrom 2.0.02.4.0

Products include Apache Atlas.

How do I fix CVE-2024-46910?

Upgrade org.apache.atlas:apache-atlas to 2.4.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-46910 being exploited?

There is no known exploitation of CVE-2024-46910 in the wild and no public exploit code.

Sources

Also known as GHSA-x3v6-f5fr-4wwv.

Is CVE-2024-46910 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free