{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.atlas:apache-atlas. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-46910 in the wild and no public exploit code.","fix":"Upgrade org.apache.atlas:apache-atlas to 2.4.0 or later.","what":"CVE-2024-46910 is a high-severity cross-site scripting vulnerability in Apache Atlas, published on 13 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-46910 and fix it if it is affected.\n\nWhat it is: CVE-2024-46910 is a high-severity cross-site scripting vulnerability in Apache Atlas, published on 13 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-46910 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.atlas:apache-atlas (Maven): affected from 2.0.0; fixed in 2.4.0\n- org.apache.atlas:apache-atlas (Maven): affected from 2.0.0; fixed in 2.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-46910/ (Markdown: https://insights.sbomify.com/CVE-2024-46910/index.md)","id":"CVE-2024-46910","markdown":"https://insights.sbomify.com/CVE-2024-46910/index.md","name":"CVE-2024-46910","record":{"aliases":["GHSA-x3v6-f5fr-4wwv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Atlas","requires_auth":"low_privilege","summary":"An authenticated user can execute cross-site scripting attacks to potentially impersonate other users in Apache Atlas.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"atlas","vendor":"apache"}],"cvss":{"score":7.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"An authenticated user can perform XSS and potentially impersonate another user.\n\nThis issue affects Apache Atlas versions 2.3.0 and earlier.\n\nUsers are recommended to upgrade to version 2.4.0, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Atlas: An authenticated user can perform XSS and potentially impersonate another user","id":"CVE-2024-46910","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Apache Roller: Weakness in CSRF protection allows privilege escalation","id":"CVE-2024-46911"},"packages":[{"ecosystem":"Maven","fixed":["2.4.0"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.atlas:apache-atlas","purl":null,"source":"GHSA-x3v6-f5fr-4wwv"},{"ecosystem":"Maven","fixed":["2.4.0"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.atlas:apache-atlas","purl":"pkg:maven/org.apache.atlas/apache-atlas","source":"GHSA-x3v6-f5fr-4wwv"}],"prev":{"headline":"WhatsUp Gold WriteDataFile Directory Traversal Remote Code Execution Vulnerability","id":"CVE-2024-46909"},"products":["Apache Atlas"],"published":"2025-02-13","related":[{"cvss_score":8.8,"headline":"Apache Atlas: Missing Authorization on Admin Endpoints","id":"CVE-2026-50622","kev_date_added":null,"published":"2026-07-29"},{"cvss_score":8.8,"headline":"Apache Atlas: zip path traversal in import functionality","id":"CVE-2022-34271","kev_date_added":null,"published":"2022-12-14"},{"cvss_score":8.1,"headline":"Apache Atlas: Script injection allows access to unintended data","id":"CVE-2026-40563","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":7.5,"headline":"Path Traversal in Apache Atlas","id":"CVE-2016-8752","kev_date_added":null,"published":"2017-08-29"},{"cvss_score":7.5,"headline":"Apache Atlas produces Stack trace in error response","id":"CVE-2017-3154","kev_date_added":null,"published":"2017-08-29"},{"cvss_score":6.1,"headline":"Cross-site scripting in Apache Atlas","id":"CVE-2020-13928","kev_date_added":null,"published":"2020-09-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-17","vendors":["Apache Software Foundation"]},"summary":"An authenticated user can execute cross-site scripting attacks to potentially impersonate other users in Apache Atlas.","url":"https://insights.sbomify.com/CVE-2024-46910/"}