# CVE-2024-46910: Apache Atlas: An authenticated user can perform XSS and potentially impersonate another user

> An authenticated user can execute cross-site scripting attacks to potentially impersonate other users in Apache Atlas.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2025
- **Updated:** 17 Oct 2025
- **Also known as:** GHSA-x3v6-f5fr-4wwv

## What is CVE-2024-46910?

CVE-2024-46910 is a high-severity cross-site scripting vulnerability in Apache Atlas, published on 13 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An authenticated user can perform XSS and potentially impersonate another user.

This issue affects Apache Atlas versions 2.3.0 and earlier.

Users are recommended to upgrade to version 2.4.0, which fixes the issue.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2024-46910?

2 open source packages ship an affected version, including org.apache.atlas:apache-atlas. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.atlas:apache-atlas` | Maven | From 2.0.0 | 2.4.0 |
| `org.apache.atlas:apache-atlas` | Maven | From 2.0.0 | 2.4.0 |

Products: Apache Atlas.

## How do I fix CVE-2024-46910?

Upgrade org.apache.atlas:apache-atlas to 2.4.0 or later.

## Is CVE-2024-46910 being exploited?

There is no known exploitation of CVE-2024-46910 in the wild and no public exploit code.

## Other vulnerabilities in Apache Atlas

- [CVE-2026-50622](https://insights.sbomify.com/CVE-2026-50622/): Apache Atlas: Missing Authorization on Admin Endpoints (high 8.8)
- [CVE-2022-34271](https://insights.sbomify.com/CVE-2022-34271/): Apache Atlas: zip path traversal in import functionality (high 8.8)
- [CVE-2026-40563](https://insights.sbomify.com/CVE-2026-40563/): Apache Atlas: Script injection allows access to unintended data (high 8.1)
- [CVE-2016-8752](https://insights.sbomify.com/CVE-2016-8752/): Path Traversal in Apache Atlas (high 7.5)
- [CVE-2017-3154](https://insights.sbomify.com/CVE-2017-3154/): Apache Atlas produces Stack trace in error response (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46910 and fix it if it is affected.

What it is: CVE-2024-46910 is a high-severity cross-site scripting vulnerability in Apache Atlas, published on 13 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-46910 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.atlas:apache-atlas (Maven): affected from 2.0.0; fixed in 2.4.0
- org.apache.atlas:apache-atlas (Maven): affected from 2.0.0; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46910/ (Markdown: https://insights.sbomify.com/CVE-2024-46910/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46910
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46910
- OSV: https://osv.dev/vulnerability/CVE-2024-46910

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46910/
Summaries are generated and may contain mistakes; the official description above is the record.
