CVE-2024-46935 Denial of service in rocket chat message parser
Attackers can crash the Rocket.Chat workspace by sending messages with specific characters, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-46935?
CVE-2024-46935 is a high-severity denial of service vulnerability in Rocket.chat Rocket.chat, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Rocket.Chat 6.12.0, 6.11.2, 6.10.5, 6.9.6, 6.8.6, 6.7.8, and earlier is vulnerable to denial of service (DoS). Attackers who craft messages with specific characters may crash the workspace due to an issue in the message parser.
Which versions are affected by CVE-2024-46935?
2 open source packages ship an affected version, including @rocket.chat/message-parser. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@rocket.chat/message-parser npm | All versions | 0.31.30 |
@rocket.chat/message-parser npm | All versions | 0.31.30 |
Products include Rocket.chat Rocket.chat.
How do I fix CVE-2024-46935?
Upgrade @rocket.chat/message-parser to 0.31.30 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-46935 being exploited?
There is no known exploitation of CVE-2024-46935 in the wild and no public exploit code.
Other vulnerabilities in Rocket.chat Rocket.chat
Sources
Also known as GHSA-6375-pg5j-8wph.