# CVE-2024-46957: Mellium allows Authentication Bypass by Spoofing

> Attackers can spoof XMPP responses by exploiting predictable IDs and missing stanza type checks in the Mellium Go library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2024
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-98hf-m87w-cq6h, GO-2024-3157

## What is CVE-2024-46957?

CVE-2024-46957 is a critical vulnerability in n/a, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mellium mellium.im/xmpp 0.0.1 through 0.21.4 allows response spoofing if the implementation uses predictable IDs because the stanza type is not checked. This is fixed in 0.22.0.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2024-46957?

3 open source packages ship an affected version, including mellium.im/xmpp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mellium.im/xmpp` | Go | All versions | 0.22.0 |
| `mellium.im/xmpp` | Go | All versions | 0.22.0 |
| `mellium.im/xmpp` | Go | All versions | 0.22.0 |

## How do I fix CVE-2024-46957?

Upgrade mellium.im/xmpp to 0.22.0 or later.

## Is CVE-2024-46957 being exploited?

There is no known exploitation of CVE-2024-46957 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46957 and fix it if it is affected.

What it is: CVE-2024-46957 is a critical vulnerability in n/a, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-46957 in the wild and no public exploit code.

Affected packages and fixed versions:
- mellium.im/xmpp (Go): affected all versions; fixed in 0.22.0
- mellium.im/xmpp (Go): affected all versions; fixed in 0.22.0
- mellium.im/xmpp (Go): affected all versions; fixed in 0.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46957/ (Markdown: https://insights.sbomify.com/CVE-2024-46957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46957
- OSV: https://osv.dev/vulnerability/CVE-2024-46957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46957/
Summaries are generated and may contain mistakes; the official description above is the record.
