# CVE-2024-46958: Misconfiguration in n/a

> Attackers can read or modify synchronized files because the Nextcloud Desktop Client incorrectly sets world-writable or world-readable permissions on Linux.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2024
- **Updated:** 13 Mar 2025
- **Also known as:** DEBIAN-CVE-2024-46958, GHSA-gcwq-2mx4-wmcp, UBUNTU-CVE-2024-46958

## What is CVE-2024-46958?

CVE-2024-46958 is a critical vulnerability in n/a, published on 16 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Nextcloud Desktop Client 3.13.1 through 3.13.3 on Linux, synchronized files (between the server and client) may become world writable or world readable. This is fixed in 3.13.4.

## Which versions are affected by CVE-2024-46958?

It affects 1 product.


Products: Nextcloud Desktop.

## How do I fix CVE-2024-46958?

Upgrade to a fixed version.

## Is CVE-2024-46958 being exploited?

There is no known exploitation of CVE-2024-46958 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-8224](https://insights.sbomify.com/CVE-2020-8224/): Code injection in Desktop Client (high 7.8)
- [CVE-2020-8225](https://insights.sbomify.com/CVE-2020-8225/): Information disclosure in Desktop Client (high 7.5)
- [CVE-2021-37617](https://insights.sbomify.com/CVE-2021-37617/): Untrusted Search Path in Nextcloud Desktop Client (high 7.3)
- [CVE-2023-28999](https://insights.sbomify.com/CVE-2023-28999/): Nextcloud: Lack of authenticity of metadata keys allows a malicious server to gain access to E2EE folders (medium 6.9)
- [CVE-2020-8227](https://insights.sbomify.com/CVE-2020-8227/): Path traversal in Desktop Client (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46958 and fix it if it is affected.

What it is: CVE-2024-46958 is a critical vulnerability in n/a, published on 16 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-46958 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46958/ (Markdown: https://insights.sbomify.com/CVE-2024-46958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46958
- OSV: https://osv.dev/vulnerability/CVE-2024-46958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46958/
Summaries are generated and may contain mistakes; the official description above is the record.
