# CVE-2024-46978: Missing checks for notification filter preferences editions in XWiki Platform

> Attackers can modify or delete other users' notification filter preferences if they know the ID, causing notification loss.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2024
- **Updated:** 20 Sep 2024
- **Also known as:** GHSA-r95w-889q-x2gx

## What is CVE-2024-46978?

CVE-2024-46978 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 18 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It's possible for any user knowing the ID of a notification filter preference of another user, to enable/disable it or even delete it. The impact is that the target user might start loosing notifications on some pages because of this. This vulnerability is present in XWiki since 13.2-rc-1. This vulnerability has been patched in XWiki 14.10.21, 15.5.5, 15.10.1, 16.0-rc-1. The patch consists in checking properly the rights of the user before performing any action on the filters. Users are advised to upgrade. It's possible to fix manually the vulnerability by editing the document `XWiki.Notifications.Code.NotificationPreferenceService` to apply the changes performed in commit e8acc9d8e6af7dfbfe70716ded431642ae4a6dd4.

Weakness: CWE-648 (Incorrect Use of Privileged APIs)

## Which versions are affected by CVE-2024-46978?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-notifications-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-notifications-ui` | Maven | From 13.2-rc-1 | 14.10.21 |
| `org.xwiki.platform:xwiki-platform-notifications-ui` | Maven | From 13.2-rc-1 | 14.10.21 |
| `org.xwiki.platform:xwiki-platform-notifications-ui` | Maven | From 15.0-rc-1 | 15.5.5 |
| `org.xwiki.platform:xwiki-platform-notifications-ui` | Maven | From 15.0-rc-1 | 15.5.5 |
| `org.xwiki.platform:xwiki-platform-notifications-ui` | Maven | From 15.6-rc-1 | 15.10.1 |
| `org.xwiki.platform:xwiki-platform-notifications-ui` | Maven | From 15.6-rc-1 | 15.10.1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-46978?

Upgrade org.xwiki.platform:xwiki-platform-notifications-ui to a fixed version for your release line: 14.10.21, 15.5.5 or 15.10.1.

## Is CVE-2024-46978 being exploited?

There is no known exploitation of CVE-2024-46978 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46978 and fix it if it is affected.

What it is: CVE-2024-46978 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 18 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-46978 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-notifications-ui (Maven): affected from 13.2-rc-1; fixed in 14.10.21
- org.xwiki.platform:xwiki-platform-notifications-ui (Maven): affected from 13.2-rc-1; fixed in 14.10.21
- org.xwiki.platform:xwiki-platform-notifications-ui (Maven): affected from 15.0-rc-1; fixed in 15.5.5
- org.xwiki.platform:xwiki-platform-notifications-ui (Maven): affected from 15.0-rc-1; fixed in 15.5.5
- org.xwiki.platform:xwiki-platform-notifications-ui (Maven): affected from 15.6-rc-1; fixed in 15.10.1
- org.xwiki.platform:xwiki-platform-notifications-ui (Maven): affected from 15.6-rc-1; fixed in 15.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46978/ (Markdown: https://insights.sbomify.com/CVE-2024-46978/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46978
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46978
- OSV: https://osv.dev/vulnerability/CVE-2024-46978

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46978/
Summaries are generated and may contain mistakes; the official description above is the record.
