CVE-2024-46982 Cache Poisoning in next.js
Attackers can poison the cache of non-dynamic server-side rendered routes in Next.js pages router, potentially serving stale or incorrect content to users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-46982?
CVE-2024-46982 is a high-severity vulnerability in Vercel Next.js, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Next.js is a React framework for building full-stack web applications. By sending a crafted HTTP request, it is possible to poison the cache of a non-dynamic server-side rendered route in the pages router (this does not affect the app router). When this crafted request is sent it could coerce Next.js to cache a route that is meant to not be cached and send a `Cache-Control: s-maxage=1, stale-while-revalidate` header which some upstream CDNs may cache as well. To be potentially affected all of the following must apply: 1. Next.js between 13.5.1 and 14.2.9, 2. Using pages router, & 3. Using non-dynamic server-side rendered routes e.g. `pages/dashboard.tsx` not `pages/blog/[slug].tsx`. This vulnerability was resolved in Next.js v13.5.7, v14.2.10, and later. We recommend upgrading regardless of whether you can reproduce the issue or not. There are no official or recommended workarounds for this issue, we recommend that users patch to a safe version.
Weakness: CWE-639
Which versions are affected by CVE-2024-46982?
4 open source packages ship an affected version, including next. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
next npm | From 13.5.1 | 13.5.7 |
next npm | From 13.5.1 | 13.5.7 |
next npm | From 14.0.0 | 14.2.10 |
next npm | From 14.0.0 | 14.2.10 |
Products include Vercel Next.js.
How do I fix CVE-2024-46982?
Upgrade next to a fixed version for your release line: 13.5.7 or 14.2.10.
Is CVE-2024-46982 being exploited?
There is no known exploitation of CVE-2024-46982 in the wild and no public exploit code.
Public exploit code: 5 proofs of concept on GitHub.
Other vulnerabilities in Vercel Next.js
- CVE-2025-29927 Authorization Bypass in Next.js Middleware
- CVE-2026-44578 Next.js: Server-side request forgery in applications using WebSocket upgrades
- CVE-2026-94483 Next.js: Server-Side Request Forgery in Image Optimization
- CVE-2026-64642 Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale
- CVE-2026-64645 Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname
Sources
Also known as GHSA-gp8f-8m3g-qvj9, MINI-g59r-xm9f-599m, ROOT-APP-NPM-CVE-2024-46982.