# CVE-2024-46982: Cache Poisoning in next.js

> Attackers can poison the cache of non-dynamic server-side rendered routes in Next.js pages router, potentially serving stale or incorrect content to users.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2024
- **Updated:** 18 Sep 2024
- **Also known as:** GHSA-gp8f-8m3g-qvj9, MINI-g59r-xm9f-599m, ROOT-APP-NPM-CVE-2024-46982

## What is CVE-2024-46982?

CVE-2024-46982 is a high-severity vulnerability in Vercel Next.js, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. By sending a crafted HTTP request, it is possible to poison the cache of a non-dynamic server-side rendered route in the pages router (this does not affect the app router). When this crafted request is sent it could coerce Next.js to cache a route that is meant to not be cached and send a `Cache-Control: s-maxage=1, stale-while-revalidate` header which some upstream CDNs may cache as well. To be potentially affected all of the following must apply: 1. Next.js between 13.5.1 and 14.2.9, 2. Using pages router, & 3. Using non-dynamic server-side rendered routes e.g. `pages/dashboard.tsx` not `pages/blog/[slug].tsx`. This vulnerability was resolved in Next.js v13.5.7, v14.2.10, and later. We recommend upgrading regardless of whether you can reproduce the issue or not. There are no official or recommended workarounds for this issue, we recommend that users patch to a safe version.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2024-46982?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 13.5.1 | 13.5.7 |
| `next` | npm | From 13.5.1 | 13.5.7 |
| `next` | npm | From 14.0.0 | 14.2.10 |
| `next` | npm | From 14.0.0 | 14.2.10 |

Products: Vercel Next.js.

## How do I fix CVE-2024-46982?

Upgrade next to a fixed version for your release line: 13.5.7 or 14.2.10.

## Is CVE-2024-46982 being exploited?

There is no known exploitation of CVE-2024-46982 in the wild and no public exploit code.

Public exploit code:

- POC CVE-2024-46982 (github_poc): https://github.com/Lercas/CVE-2024-46982
- Comprehensive demonstration of CVE-2025-32421 Eclipse technique - a sophisticated race condition attack against Next.js 15.0.4 that bypasses the original CVE-2024-46982 patch. (github_poc): https://github.com/hidesec/CVE-2025-32421
-  The CVE-2024-46982 is cache poisoning of next_js some site have API to load their image (github_poc): https://github.com/CodePontiff/next_js_poisoning
- https://github.com/melmathari/CVE-2024-46982-NUCLEI (github_poc): https://github.com/melmathari/CVE-2024-46982-NUCLEI
- Reproduction of CVE-2024-46982 (github_poc): https://github.com/samuel871211/CVE-2024-46982-Reproduction

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46982 and fix it if it is affected.

What it is: CVE-2024-46982 is a high-severity vulnerability in Vercel Next.js, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-46982 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 13.5.1; fixed in 13.5.7
- next (npm): affected from 13.5.1; fixed in 13.5.7
- next (npm): affected from 14.0.0; fixed in 14.2.10
- next (npm): affected from 14.0.0; fixed in 14.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46982/ (Markdown: https://insights.sbomify.com/CVE-2024-46982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46982
- OSV: https://osv.dev/vulnerability/CVE-2024-46982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46982/
Summaries are generated and may contain mistakes; the official description above is the record.
