{"answers":{"affected":"2 open source packages ship an affected version, including de.gematik.refv.commons:commons. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-46984 in the wild and no public exploit code.","fix":"Upgrade de.gematik.refv.commons:commons to 2.5.1 or later.","what":"CVE-2024-46984 is a high-severity vulnerability in gematik app-referencevalidator, published on 19 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-46984 and fix it if it is affected.\n\nWhat it is: CVE-2024-46984 is a high-severity vulnerability in gematik app-referencevalidator, published on 19 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-46984 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- de.gematik.refv.commons:commons (Maven): affected all versions; fixed in 2.5.1\n- de.gematik.refv.commons:commons (Maven): affected all versions; fixed in 2.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-46984/ (Markdown: https://insights.sbomify.com/CVE-2024-46984/index.md)","id":"CVE-2024-46984","markdown":"https://insights.sbomify.com/CVE-2024-46984/index.md","name":"CVE-2024-46984","record":{"aliases":["GHSA-68j8-fp38-p48q"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"FHIR validation library","requires_auth":"none","summary":"Attackers can exploit insecure XML parsing defaults to trigger Server Side Request Forgery, potentially accessing internal network resources.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"reference_validator","vendor":"gematik"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"The reference validator is a tool to perform advanced validation of FHIR resources for TI applications and interoperability standards. The profile location routine in the referencevalidator commons package is vulnerable to `XML External Entities` attack due to insecure defaults of the used Woodstox WstxInputFactory. A malicious XML resource can lead to network requests issued by referencevalidator and thus to a `Server Side Request Forgery` attack. The vulnerability impacts applications which use referencevalidator to process XML resources from untrusted sources. The problem has been patched with the 2.5.1 version of the referencevalidator. Users are strongly recommended to update to this version or a more recent one. A pre-processing or manual analysis of input XML resources on existence of DTD definitions or external entities can mitigate the problem.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Gematik Referenzvalidator has an XXE vulnerability that can lead to a Server Side Request Forgery attack","id":"CVE-2024-46984","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2024"},"n_packages":2,"n_references":6,"next":{"headline":"DataEase has an XXE vulnerability","id":"CVE-2024-46985"},"packages":[{"ecosystem":"Maven","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"de.gematik.refv.commons:commons","purl":null,"source":"GHSA-68j8-fp38-p48q"},{"ecosystem":"Maven","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"de.gematik.refv.commons:commons","purl":"pkg:maven/de.gematik.refv.commons/commons","source":"GHSA-68j8-fp38-p48q"}],"prev":{"headline":"Remote Command Execution(RCE) Vulnerbility in sofa-hessian","id":"CVE-2024-46983"},"products":["app-referencevalidator"],"published":"2024-09-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-20","vendors":["gematik"]},"summary":"Attackers can exploit insecure XML parsing defaults to trigger Server Side Request Forgery, potentially accessing internal network resources.","url":"https://insights.sbomify.com/CVE-2024-46984/"}