# CVE-2024-46985: DataEase has an XXE vulnerability

> An attacker can exploit an XML external entity injection flaw in DataEase to read files and detect intranet resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2024
- **Updated:** 23 Sep 2024
- **Also known as:** GHSA-4m9p-7xg6-f4mm

## What is CVE-2024-46985?

CVE-2024-46985 is a high-severity vulnerability in Dataease Dataease, published on 23 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DataEase is an open source data visualization analysis tool. Prior to version 2.10.1, there is an XML external entity injection vulnerability in the static resource upload interface of DataEase. An attacker can construct a payload to implement intranet detection and file reading. The vulnerability has been fixed in v2.10.1.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-46985?

2 open source packages ship an affected version, including io.dataease:common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.dataease:common` | Maven | All versions | 2.10.1 |
| `io.dataease:common` | Maven | All versions | 2.10.1 |

Products: Dataease Dataease.

## How do I fix CVE-2024-46985?

Upgrade io.dataease:common to 2.10.1 or later.

## Is CVE-2024-46985 being exploited?

There is no known exploitation of CVE-2024-46985 in the wild and no public exploit code.

## Other vulnerabilities in Dataease Dataease

- [CVE-2024-57707](https://insights.sbomify.com/CVE-2024-57707/): Code injection in n/a (critical 9.8)
- [CVE-2024-46997](https://insights.sbomify.com/CVE-2024-46997/): DataEase's H2 datasource has a remote command execution risk (critical 9.8)
- [CVE-2023-33963](https://insights.sbomify.com/CVE-2023-33963/): DataEase data source has deserialization vulnerability (critical 9.8)
- [CVE-2023-28437](https://insights.sbomify.com/CVE-2023-28437/): SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed (critical 9.8)
- [CVE-2022-39312](https://insights.sbomify.com/CVE-2022-39312/): Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46985 and fix it if it is affected.

What it is: CVE-2024-46985 is a high-severity vulnerability in Dataease Dataease, published on 23 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-46985 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.dataease:common (Maven): affected all versions; fixed in 2.10.1
- io.dataease:common (Maven): affected all versions; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46985/ (Markdown: https://insights.sbomify.com/CVE-2024-46985/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46985
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46985
- OSV: https://osv.dev/vulnerability/CVE-2024-46985

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46985/
Summaries are generated and may contain mistakes; the official description above is the record.
