# CVE-2024-46987: Arbitrary path traversal in Camaleon CMS

> Authenticated attackers can exploit a path traversal flaw in Camaleon CMS to download arbitrary files from the server, leading to information disclosure.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2024
- **Updated:** 17 Apr 2025
- **Also known as:** GHSA-cp65-5m9r-vc2c

## What is CVE-2024-46987?

CVE-2024-46987 is a high-severity path traversal vulnerability in owen2345 camaleon-cms, published on 18 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Camaleon CMS is a dynamic and advanced content management system based on Ruby on Rails. A path traversal vulnerability accessible via MediaController's download_private_file method allows authenticated users to download any file on the web server Camaleon CMS is running on (depending on the file permissions). This issue may lead to Information Disclosure. This issue has been addressed in release version 2.8.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-46987?

2 open source packages ship an affected version, including camaleon_cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `camaleon_cms` | RubyGems | All versions | 2.8.1 |
| `camaleon_cms` | RubyGems | All versions | 2.8.1 |

Products: Tuzitio Camaleon Cms.

## How do I fix CVE-2024-46987?

Upgrade camaleon_cms to 2.8.1 or later.

## Is CVE-2024-46987 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46987 exists.

Public exploit code:

- This Python PoC exploits CVE-2024-46987, a Path Traversal bug in Camaleon CMS 2.8.0 < 2.8.2  (work on 2.9.0). It allows authenticated users to read sensitive server files via the MediaController. Intended for authorized security auditing and educational research only.  (github_poc): https://github.com/Goultarde/CVE-2024-46987
- Exploit created using Python (github_poc): https://github.com/advaitpathak21/CVE-2024-46987
- Camaleon CMS Directory Traversal CVE-2024-46987 (metasploit)
- Path Traversal vulnerability (github_poc): https://github.com/L1337Xi/CVE-2024-46987
- https://github.com/Ik0nw/CVE-2024-46987 (github_poc): https://github.com/Ik0nw/CVE-2024-46987
- Exploit for CVE-2024-46987 (github_poc): https://github.com/sparrowhawk1113/Exploit-for-CVE-2024-46987

## Other vulnerabilities in owen2345 camaleon-cms

- [CVE-2024-46986](https://insights.sbomify.com/CVE-2024-46986/): Arbitrary file write leading to RCE in Camaleon CMS (critical 10.0)
- [CVE-2023-30145](https://insights.sbomify.com/CVE-2023-30145/): Server-Side Template Injection in Camaleon CMS (critical 9.8)
- [CVE-2021-25970](https://insights.sbomify.com/CVE-2021-25970/): Camaleon CMS - Insufficient Session Expiration after Password Change (high 8.8)
- [CVE-2021-25969](https://insights.sbomify.com/CVE-2021-25969/): Camaleon CMS - Stored Cross-Site Scripting (XSS) in Comments (medium 6.1)
- [CVE-2018-18260](https://insights.sbomify.com/CVE-2018-18260/): Camaleon CMS vulnerable to Stored Cross-site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-46987 and fix it if it is affected.

What it is: CVE-2024-46987 is a high-severity path traversal vulnerability in owen2345 camaleon-cms, published on 18 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-46987 exists.

Affected packages and fixed versions:
- camaleon_cms (RubyGems): affected all versions; fixed in 2.8.1
- camaleon_cms (RubyGems): affected all versions; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-46987/ (Markdown: https://insights.sbomify.com/CVE-2024-46987/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-46987
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-46987
- OSV: https://osv.dev/vulnerability/CVE-2024-46987

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-46987/
Summaries are generated and may contain mistakes; the official description above is the record.
