{"answers":{"affected":"2 open source packages ship an affected version, including io.dataease:common. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-46997 in the wild and no public exploit code.","fix":"Upgrade io.dataease:common to 2.10.1 or later.","what":"CVE-2024-46997 is a critical vulnerability in Dataease Dataease, published on 23 Sep 2024."},"fix_prompt":"Check this codebase for CVE-2024-46997 and fix it if it is affected.\n\nWhat it is: CVE-2024-46997 is a critical vulnerability in Dataease Dataease, published on 23 Sep 2024. \nExploitation: There is no known exploitation of CVE-2024-46997 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.dataease:common (Maven): affected all versions; fixed in 2.10.1\n- io.dataease:common (Maven): affected all versions; fixed in 2.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-46997/ (Markdown: https://insights.sbomify.com/CVE-2024-46997/index.md)","id":"CVE-2024-46997","markdown":"https://insights.sbomify.com/CVE-2024-46997/index.md","name":"CVE-2024-46997","record":{"aliases":["GHSA-h7mj-m72h-qm8w"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"dataease","vendor":"dataease"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"DataEase is an open source data visualization analysis tool. Prior to version 2.10.1, an attacker can achieve remote command execution by adding a carefully constructed h2 data source connection string. The vulnerability has been fixed in v2.10.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DataEase's H2 datasource has a remote command execution risk","id":"CVE-2024-46997","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"dataease:dataease","products":["dataease:dataease"],"type":null,"year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"baserCMS has a Cross-site Scripting (XSS) Vulnerability in Edit Email Form Settings Feature","id":"CVE-2024-46998"},"packages":[{"ecosystem":"Maven","fixed":["2.10.1"],"introduced":["0"],"last_affected":[],"package":"io.dataease:common","purl":null,"source":"GHSA-h7mj-m72h-qm8w"},{"ecosystem":"Maven","fixed":["2.10.1"],"introduced":["0"],"last_affected":[],"package":"io.dataease:common","purl":"pkg:maven/io.dataease/common","source":"GHSA-h7mj-m72h-qm8w"}],"prev":{"headline":"baserCMS has a Cross-site Scripting (XSS) Vulnerability in Blog posts Feature","id":"CVE-2024-46996"},"products":["dataease"],"published":"2024-09-23","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2024-57707","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":9.8,"headline":"DataEase data source has deserialization vulnerability","id":"CVE-2023-33963","kev_date_added":null,"published":"2023-06-01"},{"cvss_score":9.8,"headline":"SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed","id":"CVE-2023-28437","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":9.8,"headline":"Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability","id":"CVE-2022-39312","kev_date_added":null,"published":"2022-10-25"},{"cvss_score":9.8,"headline":"Dataease before 1.11.2 allows arbitrary code execution via crafter plugin","id":"CVE-2022-34113","kev_date_added":null,"published":"2022-07-22"},{"cvss_score":9.8,"headline":"Dataease v1.11.1 SQL Injection via parameter dataSourceId","id":"CVE-2022-34115","kev_date_added":null,"published":"2022-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-23","vendors":["dataease"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-46997/"}