# CVE-2024-47003: DoS via non-string message using permalink embed

> An attacker can crash the Mattermost frontend by sending a non-string value as a permalink message, causing a denial of service.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2024
- **Updated:** 26 Sep 2024
- **Also known as:** BIT-mattermost-2024-47003, GHSA-59hf-mpf8-pqjh, GO-2024-3164

## What is CVE-2024-47003?

CVE-2024-47003 is a low-severity denial of service vulnerability in Mattermost Mattermost Server, published on 26 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 9.11.x <= 9.11.0 and 9.5.x <= 9.5.8 fail to validate that the message of the permalink post is a string, which allows an attacker to send a non-string value as the message of a permalink post and crash the frontend.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-47003?

7 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20240806094731-69a8b3df0f9f |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20240806094731-69a8b3df0f9f |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20240806094731-69a8b3df0f9f |
| `mattermost` | Bitnami | From 9.5.0 to 9.11.0-rc1 | 9.5.9 |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2024-47003?

Upgrade github.com/mattermost/mattermost/server/v8 to 8.0.0-20240806094731-69a8b3df0f9f or later.

## Is CVE-2024-47003 being exploited?

There is no known exploitation of CVE-2024-47003 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47003 and fix it if it is affected.

What it is: CVE-2024-47003 is a low-severity denial of service vulnerability in Mattermost Mattermost Server, published on 26 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47003 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20240806094731-69a8b3df0f9f
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20240806094731-69a8b3df0f9f
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20240806094731-69a8b3df0f9f
- mattermost (Bitnami): affected from 9.5.0 up to 9.11.0-rc1; fixed in 9.5.9
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47003/ (Markdown: https://insights.sbomify.com/CVE-2024-47003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47003
- OSV: https://osv.dev/vulnerability/CVE-2024-47003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47003/
Summaries are generated and may contain mistakes; the official description above is the record.
