# CVE-2024-47049: czim/file-handling vulnerable to SSRF and directory traversal

> Attackers can exploit improper URL validation to perform Server-Side Request Forgery and read local files via directory traversal.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2024
- **Updated:** 18 Mar 2025
- **Also known as:** GHSA-6rgh-r6j3-3223

## What is CVE-2024-47049?

CVE-2024-47049 is a high-severity server-side request forgery vulnerability in n/a, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The czim/file-handling package before 1.5.0 and 2.x before 2.3.0 (used with PHP Composer) does not properly validate URLs within makeFromUrl and makeFromAny, leading to SSRF, and to directory traversal for the reading of local files.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-47049?

4 open source packages ship an affected version, including czim/file-handling. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `czim/file-handling` | Packagist | All versions | 1.5.0 |
| `czim/file-handling` | Packagist | All versions | 1.5.0 |
| `czim/file-handling` | Packagist | From 2.0.0 | 2.3.0 |
| `czim/file-handling` | Packagist | From 2.0.0 | 2.3.0 |

Products: Czim File-Handling.

## How do I fix CVE-2024-47049?

Upgrade czim/file-handling to a fixed version for your release line: 1.5.0 or 2.3.0.

## Is CVE-2024-47049 being exploited?

There is no known exploitation of CVE-2024-47049 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47049 and fix it if it is affected.

What it is: CVE-2024-47049 is a high-severity server-side request forgery vulnerability in n/a, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47049 in the wild and no public exploit code.

Affected packages and fixed versions:
- czim/file-handling (Packagist): affected all versions; fixed in 1.5.0
- czim/file-handling (Packagist): affected all versions; fixed in 1.5.0
- czim/file-handling (Packagist): affected from 2.0.0; fixed in 2.3.0
- czim/file-handling (Packagist): affected from 2.0.0; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47049/ (Markdown: https://insights.sbomify.com/CVE-2024-47049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47049
- OSV: https://osv.dev/vulnerability/CVE-2024-47049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47049/
Summaries are generated and may contain mistakes; the official description above is the record.
