# CVE-2024-47051: Remote Code Execution & File Deletion in Asset Uploads

> Authenticated attackers can upload executable files for remote code execution or delete arbitrary files via path traversal in Mautic.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2025
- **Updated:** 26 Feb 2025
- **Also known as:** GHSA-73gx-x7r9-77x2

## What is CVE-2024-47051?

CVE-2024-47051 is a critical vulnerability in mautic/core, published on 26 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

This advisory addresses two critical security vulnerabilities present in Mautic versions before 5.2.3. These vulnerabilities could be exploited by authenticated users.

  *  Remote Code Execution (RCE) via Asset Upload: A Remote Code Execution vulnerability has been identified in the asset upload functionality. Insufficient enforcement of allowed file extensions allows an attacker to bypass restrictions and upload executable files, such as PHP scripts.

  *  Path Traversal File Deletion: A Path Traversal vulnerability exists in the upload validation process. Due to improper handling of path components, an authenticated user can manipulate the file deletion process to delete arbitrary files on the host system.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2024-47051?

2 open source packages ship an affected version, including mautic/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mautic/core` | Packagist | All versions | 5.2.3 |
| `mautic/core` | Packagist | All versions | 5.2.3 |

Products: Acquia Mautic.

## How do I fix CVE-2024-47051?

Upgrade mautic/core to 5.2.3 or later.

## Is CVE-2024-47051 being exploited?

There is no known exploitation of CVE-2024-47051 in the wild and no public exploit code.

Public exploit code:

- Mautic < 5.2.3 Authenticated RCE (github_poc): https://github.com/mallo-m/CVE-2024-47051
- CVE-2024-47051 (github_poc): https://github.com/hyeonyeonglee/CVE-2024-47051

## Other vulnerabilities in mautic/core

- [CVE-2022-25772](https://insights.sbomify.com/CVE-2022-25772/): Cross-site Scripting vulnerability in Mautic's tracking pixel functionality (critical 9.6)
- [CVE-2020-35125](https://insights.sbomify.com/CVE-2020-35125/): Mautic is vulnerable to XSS vulnerability (critical 9.6)
- [CVE-2020-35124](https://insights.sbomify.com/CVE-2020-35124/): XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic (critical 9.6)
- [CVE-2020-35128](https://insights.sbomify.com/CVE-2020-35128/): Mautic stored Cross-site Scripting (XSS) (critical 9.0)
- [CVE-2017-8874](https://insights.sbomify.com/CVE-2017-8874/): Mautic Cross-Site Request Forgery (CSRF) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47051 and fix it if it is affected.

What it is: CVE-2024-47051 is a critical vulnerability in mautic/core, published on 26 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47051 in the wild and no public exploit code.

Affected packages and fixed versions:
- mautic/core (Packagist): affected all versions; fixed in 5.2.3
- mautic/core (Packagist): affected all versions; fixed in 5.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47051/ (Markdown: https://insights.sbomify.com/CVE-2024-47051/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47051
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47051
- OSV: https://osv.dev/vulnerability/CVE-2024-47051

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47051/
Summaries are generated and may contain mistakes; the official description above is the record.
