# CVE-2024-47059: Users enumeration - weak password login

> Attackers can enumerate valid usernames by observing distinct error messages for weak passwords versus invalid credentials in Mautic.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2024
- **Updated:** 25 Sep 2024
- **Also known as:** GHSA-8vff-35qm-qjvv

## What is CVE-2024-47059?

CVE-2024-47059 is a medium-severity vulnerability in Mautic, published on 18 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When logging in with the correct username and incorrect weak password, the user receives the notification, that their password is too weak.

However when an incorrect username is provided alongside with a weak password, the application responds with ’Invalid credentials’ notification.

This difference could be used to perform username enumeration.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-47059?

2 open source packages ship an affected version, including mautic/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mautic/core` | Packagist | From 5.1.0 | 5.1.1 |
| `mautic/core` | Packagist | From 5.1.0 | 5.1.1 |

Products: Acquia Mautic.

## How do I fix CVE-2024-47059?

Upgrade mautic/core to 5.1.1 or later.

## Is CVE-2024-47059 being exploited?

There is no known exploitation of CVE-2024-47059 in the wild and no public exploit code.

## Other vulnerabilities in Mautic

- [CVE-2022-25772](https://insights.sbomify.com/CVE-2022-25772/): Cross-site Scripting vulnerability in Mautic's tracking pixel functionality (critical 9.6)
- [CVE-2020-35125](https://insights.sbomify.com/CVE-2020-35125/): Mautic is vulnerable to XSS vulnerability (critical 9.6)
- [CVE-2020-35124](https://insights.sbomify.com/CVE-2020-35124/): XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic (critical 9.6)
- [CVE-2024-47051](https://insights.sbomify.com/CVE-2024-47051/): Remote Code Execution & File Deletion in Asset Uploads (critical 9.1)
- [CVE-2020-35128](https://insights.sbomify.com/CVE-2020-35128/): Mautic stored Cross-site Scripting (XSS) (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47059 and fix it if it is affected.

What it is: CVE-2024-47059 is a medium-severity vulnerability in Mautic, published on 18 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47059 in the wild and no public exploit code.

Affected packages and fixed versions:
- mautic/core (Packagist): affected from 5.1.0; fixed in 5.1.1
- mautic/core (Packagist): affected from 5.1.0; fixed in 5.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47059/ (Markdown: https://insights.sbomify.com/CVE-2024-47059/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47059
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47059
- OSV: https://osv.dev/vulnerability/CVE-2024-47059

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47059/
Summaries are generated and may contain mistakes; the official description above is the record.
