{"answers":{"affected":"2 open source packages ship an affected version, including @lobehub/chat. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47066 exists.","fix":"Upgrade @lobehub/chat to 1.19.13 or later.","what":"CVE-2024-47066 is a critical server-side request forgery vulnerability in lobehub lobe-chat, published on 23 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-47066 and fix it if it is affected.\n\nWhat it is: CVE-2024-47066 is a critical server-side request forgery vulnerability in lobehub lobe-chat, published on 23 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47066 exists.\n\nAffected packages and fixed versions:\n- @lobehub/chat (npm): affected all versions; fixed in 1.19.13\n- @lobehub/chat (npm): affected all versions; fixed in 1.19.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-47066/ (Markdown: https://insights.sbomify.com/CVE-2024-47066/index.md)","id":"CVE-2024-47066","markdown":"https://insights.sbomify.com/CVE-2024-47066/index.md","name":"CVE-2024-47066","record":{"aliases":["GHSA-3fc8-2r3f-8wrg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"AI chat framework","requires_auth":"high_privilege","summary":"Attackers can bypass SSRF protections in Lobe Chat to access internal network resources via malicious redirects.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lobe_chat","vendor":"lobehub"}],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Lobe Chat is an open-source artificial intelligence chat framework. Prior to version 1.19.13, server-side request forgery protection implemented in `src/app/api/proxy/route.ts` does not consider redirect and could be bypassed when attacker provides an external malicious URL which redirects to internal resources like a private network or loopback address. Version 1.19.13 contains an improved fix for the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2024-09-24","github_poc":1,"max_poc_stars":4,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-09-24T09:59:27Z","kind":"github_poc","ref":"https://github.com/l8BL/CVE-2024-47066","stars":4,"title":"Proof-of-Concept for CVE-2024-47066"}],"tier":"weaponised"},"has_fix":true,"headline":"Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964)","id":"CVE-2024-47066","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"Alist Contains a Reflected Cross-Site Scripting Vulnerability","id":"CVE-2024-47067"},"packages":[{"ecosystem":"npm","fixed":["1.19.13"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":null,"source":"GHSA-3fc8-2r3f-8wrg"},{"ecosystem":"npm","fixed":["1.19.13"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":"pkg:npm/%40lobehub/chat","source":"GHSA-3fc8-2r3f-8wrg"}],"prev":{"headline":"Traceroute_APP responses are not rate-limited.","id":"CVE-2024-47065"},"products":["lobe-chat"],"published":"2024-09-23","related":[{"cvss_score":9,"headline":"lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability","id":"CVE-2024-32964","kev_date_added":null,"published":"2024-05-10"},{"cvss_score":8.1,"headline":"ssrf vulnerability in lobe-chat","id":"CVE-2024-32965","kev_date_added":null,"published":"2024-11-26"},{"cvss_score":6.8,"headline":"Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages","id":"CVE-2025-59417","kev_date_added":null,"published":"2025-09-18"},{"cvss_score":5.7,"headline":"API Key Leak in lobe-chat","id":"CVE-2024-37895","kev_date_added":null,"published":"2024-06-17"},{"cvss_score":5.3,"headline":"Lobe Chat unauthorized access to plugins","id":"CVE-2024-24566","kev_date_added":null,"published":"2024-01-31"},{"cvss_score":4.3,"headline":"lobe-chat has an Open Redirect","id":"CVE-2025-59426","kev_date_added":null,"published":"2025-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-23","vendors":["lobehub"]},"summary":"Attackers can bypass SSRF protections in Lobe Chat to access internal network resources via malicious redirects.","url":"https://insights.sbomify.com/CVE-2024-47066/"}