# CVE-2024-47067: Alist Contains a Reflected Cross-Site Scripting Vulnerability

> Attackers can execute arbitrary scripts in victim browsers via reflected XSS in the /i/:link_name endpoint of Alist.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Sep 2024
- **Updated:** 30 Sep 2024
- **Also known as:** GHSA-8pph-gfhp-w226, GO-2024-3190

## What is CVE-2024-47067?

CVE-2024-47067 is a medium-severity cross-site scripting vulnerability in alist-org alist, published on 30 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

AList is a file list program that supports multiple storages. AList contains a reflected cross-site scripting vulnerability in helper.go. The endpoint /i/:link_name takes in a user-provided value and reflects it back in the response. The endpoint returns an application/xml response, opening it up to HTML tags via XHTML and thus leading to a XSS vulnerability. This vulnerability is fixed in 3.29.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-47067?

4 open source packages ship an affected version, including github.com/alist-org/alist/v3 and github.com/alist-org/alist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/alist-org/alist/v3` | Go | All versions | 3.29.0 |
| `github.com/alist-org/alist/v3` | Go | All versions | 3.29.0 |
| `github.com/alist-org/alist/v3` | Go | All versions | 3.29.0 |
| `github.com/alist-org/alist` | Go | All versions | None |

Products: Alistgo Alist.

## How do I fix CVE-2024-47067?

Upgrade github.com/alist-org/alist/v3 to 3.29.0 or later.

## Is CVE-2024-47067 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47067 exists.

## Other vulnerabilities in alist-org alist

- [CVE-2022-45969](https://insights.sbomify.com/CVE-2022-45969/): Alist vulnerable to Path Traversal (critical 9.8)
- [CVE-2026-25160](https://insights.sbomify.com/CVE-2026-25160/): Alist has Insecure TLS Config (critical 9.1)
- [CVE-2026-25161](https://insights.sbomify.com/CVE-2026-25161/): Alist vulnerable to Path Traversal in multiple file operation handlers (high 8.8)
- [CVE-2023-33498](https://insights.sbomify.com/CVE-2023-33498/): alist Incorrect Access Control vulnerability (high 8.8)
- [CVE-2022-45968](https://insights.sbomify.com/CVE-2022-45968/): AList vulnerable to Improper Preservation of Permissions (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47067 and fix it if it is affected.

What it is: CVE-2024-47067 is a medium-severity cross-site scripting vulnerability in alist-org alist, published on 30 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47067 exists.

Affected packages and fixed versions:
- github.com/alist-org/alist/v3 (Go): affected all versions; fixed in 3.29.0
- github.com/alist-org/alist/v3 (Go): affected all versions; fixed in 3.29.0
- github.com/alist-org/alist/v3 (Go): affected all versions; fixed in 3.29.0
- github.com/alist-org/alist (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47067/ (Markdown: https://insights.sbomify.com/CVE-2024-47067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47067
- OSV: https://osv.dev/vulnerability/CVE-2024-47067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47067/
Summaries are generated and may contain mistakes; the official description above is the record.
