# CVE-2024-47068: DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS

> Attacker can execute arbitrary JavaScript via DOM clobbering in bundled scripts using import.meta properties in specific output formats.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2024
- **Updated:** 29 Oct 2024
- **Also known as:** CLSA-2026-1774570949, CLSA-2026-1774830282, CLSA-2026-1775089651, CLSA-2026-1775089653, CLSA-2026-1775089660, CLSA-2026-1784682991, DEBIAN-CVE-2024-47068, GHSA-gcx4-mw62-g8wm, MINI-vhfm-wmcv-43jm, ROOT-APP-NPM-CVE-2024-47068, UBUNTU-CVE-2024-47068

## What is CVE-2024-47068?

CVE-2024-47068 is a medium-severity cross-site scripting vulnerability in rollup, published on 23 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Rollup is a module bundler for JavaScript. Versions prior to 2.79.2, 3.29.5, and 4.22.4 are susceptible to a DOM Clobbering vulnerability when bundling scripts with properties from `import.meta` (e.g., `import.meta.url`) in `cjs`/`umd`/`iife` format. The DOM Clobbering gadget can lead to cross-site scripting (XSS) in web pages where scriptless attacker-controlled HTML elements (e.g., an `img` tag with an unsanitized `name` attribute) are present. Versions 2.79.2, 3.29.5, and 4.22.4  contain a patch for the vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-47068?

6 open source packages ship an affected version, including rollup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rollup` | npm | All versions | 2.79.2 |
| `rollup` | npm | All versions | 2.79.2 |
| `rollup` | npm | From 3.0.0 | 3.29.5 |
| `rollup` | npm | From 3.0.0 | 3.29.5 |
| `rollup` | npm | From 4.0.0 | 4.22.4 |
| `rollup` | npm | From 4.0.0 | 4.22.4 |

Products: Rollupjs Rollup.

## How do I fix CVE-2024-47068?

Upgrade rollup to a fixed version for your release line: 2.79.2, 3.29.5 or 4.22.4.

## Is CVE-2024-47068 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47068 exists.

## Other vulnerabilities in rollup

- [CVE-2026-27606](https://insights.sbomify.com/CVE-2026-27606/): Rollup 4 has Arbitrary File Write via Path Traversal (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47068 and fix it if it is affected.

What it is: CVE-2024-47068 is a medium-severity cross-site scripting vulnerability in rollup, published on 23 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47068 exists.

Affected packages and fixed versions:
- rollup (npm): affected all versions; fixed in 2.79.2
- rollup (npm): affected all versions; fixed in 2.79.2
- rollup (npm): affected from 3.0.0; fixed in 3.29.5
- rollup (npm): affected from 3.0.0; fixed in 3.29.5
- rollup (npm): affected from 4.0.0; fixed in 4.22.4
- rollup (npm): affected from 4.0.0; fixed in 4.22.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47068/ (Markdown: https://insights.sbomify.com/CVE-2024-47068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47068
- OSV: https://osv.dev/vulnerability/CVE-2024-47068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47068/
Summaries are generated and may contain mistakes; the official description above is the record.
