{"answers":{"affected":"4 open source packages ship an affected version, including oveleon/contao-cookiebar. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47069 exists.","fix":"Upgrade oveleon/contao-cookiebar to a fixed version for your release line: 1.16.3 or 2.1.3.","what":"CVE-2024-47069 is a medium-severity cross-site scripting vulnerability in oveleon contao-cookiebar, published on 23 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-47069 and fix it if it is affected.\n\nWhat it is: CVE-2024-47069 is a medium-severity cross-site scripting vulnerability in oveleon contao-cookiebar, published on 23 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47069 exists.\n\nAffected packages and fixed versions:\n- oveleon/contao-cookiebar (Packagist): affected all versions; fixed in 1.16.3\n- oveleon/contao-cookiebar (Packagist): affected all versions; fixed in 1.16.3\n- oveleon/contao-cookiebar (Packagist): affected from 2.0.0; fixed in 2.1.3\n- oveleon/contao-cookiebar (Packagist): affected from 2.0.0; fixed in 2.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-47069/ (Markdown: https://insights.sbomify.com/CVE-2024-47069/index.md)","id":"CVE-2024-47069","markdown":"https://insights.sbomify.com/CVE-2024-47069/index.md","name":"CVE-2024-47069","record":{"aliases":["GHSA-296q-rj83-g9rq"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Contao CMS plugin","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in the backend via unsanitized locale input in the Oveleon Cookie Bar plugin for Contao CMS.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cookiebar","vendor":"oveleon"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Oveleon Cookie Bar is a cookie bar is for the Contao Open Source CMS and allows a visitor to define cookie \u0026 privacy settings for the website. Prior to versions 1.16.3 and 2.1.3, the `block/locale` endpoint does not properly sanitize the user-controlled `locale` input before including it in the backend's HTTP response, thereby causing reflected cross-site scripting. Versions 1.16.3 and 2.1.3 contain a patch for the vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Oveleon Cookiebar reflected Cross-site Scripting vulnerability","id":"CVE-2024-47069","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":4,"n_references":4,"next":{"headline":"authentik vulnerable to password authentication bypass via X-Forwarded-For HTTP header","id":"CVE-2024-47070"},"packages":[{"ecosystem":"Packagist","fixed":["1.16.3"],"introduced":["0"],"last_affected":[],"package":"oveleon/contao-cookiebar","purl":null,"source":"GHSA-296q-rj83-g9rq"},{"ecosystem":"Packagist","fixed":["1.16.3"],"introduced":["0"],"last_affected":[],"package":"oveleon/contao-cookiebar","purl":"pkg:composer/oveleon/contao-cookiebar","source":"GHSA-296q-rj83-g9rq"},{"ecosystem":"Packagist","fixed":["2.1.3"],"introduced":["2.0.0"],"last_affected":[],"package":"oveleon/contao-cookiebar","purl":null,"source":"GHSA-296q-rj83-g9rq"},{"ecosystem":"Packagist","fixed":["2.1.3"],"introduced":["2.0.0"],"last_affected":[],"package":"oveleon/contao-cookiebar","purl":"pkg:composer/oveleon/contao-cookiebar","source":"GHSA-296q-rj83-g9rq"}],"prev":{"headline":"DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS","id":"CVE-2024-47068"},"products":["contao-cookiebar"],"published":"2024-09-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-23","vendors":["oveleon"]},"summary":"Attackers can execute arbitrary scripts in the backend via unsanitized locale input in the Oveleon Cookie Bar plugin for Contao CMS.","url":"https://insights.sbomify.com/CVE-2024-47069/"}