# CVE-2024-47069: Oveleon Cookiebar reflected Cross-site Scripting vulnerability

> Attackers can execute arbitrary scripts in the backend via unsanitized locale input in the Oveleon Cookie Bar plugin for Contao CMS.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2024
- **Updated:** 23 Sep 2024
- **Also known as:** GHSA-296q-rj83-g9rq

## What is CVE-2024-47069?

CVE-2024-47069 is a medium-severity cross-site scripting vulnerability in oveleon contao-cookiebar, published on 23 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Oveleon Cookie Bar is a cookie bar is for the Contao Open Source CMS and allows a visitor to define cookie & privacy settings for the website. Prior to versions 1.16.3 and 2.1.3, the `block/locale` endpoint does not properly sanitize the user-controlled `locale` input before including it in the backend's HTTP response, thereby causing reflected cross-site scripting. Versions 1.16.3 and 2.1.3 contain a patch for the vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-47069?

4 open source packages ship an affected version, including oveleon/contao-cookiebar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oveleon/contao-cookiebar` | Packagist | All versions | 1.16.3 |
| `oveleon/contao-cookiebar` | Packagist | All versions | 1.16.3 |
| `oveleon/contao-cookiebar` | Packagist | From 2.0.0 | 2.1.3 |
| `oveleon/contao-cookiebar` | Packagist | From 2.0.0 | 2.1.3 |

Products: Oveleon Cookiebar.

## How do I fix CVE-2024-47069?

Upgrade oveleon/contao-cookiebar to a fixed version for your release line: 1.16.3 or 2.1.3.

## Is CVE-2024-47069 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47069 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47069 and fix it if it is affected.

What it is: CVE-2024-47069 is a medium-severity cross-site scripting vulnerability in oveleon contao-cookiebar, published on 23 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47069 exists.

Affected packages and fixed versions:
- oveleon/contao-cookiebar (Packagist): affected all versions; fixed in 1.16.3
- oveleon/contao-cookiebar (Packagist): affected all versions; fixed in 1.16.3
- oveleon/contao-cookiebar (Packagist): affected from 2.0.0; fixed in 2.1.3
- oveleon/contao-cookiebar (Packagist): affected from 2.0.0; fixed in 2.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47069/ (Markdown: https://insights.sbomify.com/CVE-2024-47069/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47069
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47069
- OSV: https://osv.dev/vulnerability/CVE-2024-47069

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47069/
Summaries are generated and may contain mistakes; the official description above is the record.
