# CVE-2024-47070: authentik vulnerable to password authentication bypass via X-Forwarded-For HTTP header

> Attackers can bypass password authentication and log into any account if the server trusts malformed X-Forwarded-For headers.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2024
- **Updated:** 27 Sep 2024
- **Also known as:** BIT-authentik-2024-47070, GHSA-7jxf-mmg9-9hg7

## What is CVE-2024-47070?

CVE-2024-47070 is a critical authentication bypass vulnerability in goauthentik authentik, published on 27 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

authentik is an open-source identity provider. A vulnerability that exists in versions prior to 2024.8.3 and 2024.6.5 allows bypassing password login by adding X-Forwarded-For header with an unparsable IP address, e.g. `a`. This results in a possibility of logging into any account with a known login or email address. The vulnerability requires the authentik instance to trust X-Forwarded-For header provided by the attacker, thus it is not reproducible from external hosts on a properly configured environment.  The issue occurs due to the password stage having a policy bound to it, which skips the password stage if the Identification stage is setup to also contain a password stage. Due to the invalid X-Forwarded-For header, which does not get validated to be an IP Address early enough, the exception happens later and the policy fails. The default blueprint doesn't correctly set `failure_result` to `True` on the policy binding meaning that due to this exception the policy returns false and the password stage is skipped. Versions 2024.8.3 and 2024.6.5 fix this issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-47070?

1 open source package ship an affected version, including authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2024.6.5, 2024.8.3 |

Products: Goauthentik Authentik.

## How do I fix CVE-2024-47070?

Upgrade authentik to a fixed version for your release line: 2024.6.5 or 2024.8.3.

## Is CVE-2024-47070 being exploited?

There is no known exploitation of CVE-2024-47070 in the wild and no public exploit code.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47070 and fix it if it is affected.

What it is: CVE-2024-47070 is a critical authentication bypass vulnerability in goauthentik authentik, published on 27 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47070 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2024.6.5, 2024.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47070/ (Markdown: https://insights.sbomify.com/CVE-2024-47070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47070
- OSV: https://osv.dev/vulnerability/CVE-2024-47070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47070/
Summaries are generated and may contain mistakes; the official description above is the record.
