# CVE-2024-47072: XStream is vulnerable to a Denial of Service attack due to stack overflow from a manipulated binary input stream

> Remote attackers can cause application crashes via stack overflow in XStream when using the BinaryStreamDriver, requiring an upgrade to fix.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2024
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-47072, GHSA-hfq9-hggm-c56q, OESA-2024-2400, RHLW-2026-f1a22cabc5a36f13, ROOT-APP-MAVEN-CVE-2024-47072, SUSE-SU-2024:4037-1, UBUNTU-CVE-2024-47072, openSUSE-SU-2024:14480-1

## What is CVE-2024-47072?

CVE-2024-47072 is a high-severity denial of service vulnerability in x-stream xstream, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XStream is a simple library to serialize objects to XML and back again. This vulnerability may allow a remote attacker to terminate the application with a stack overflow error resulting in a denial of service only by manipulating the processed input stream when XStream is configured to use the BinaryStreamDriver. XStream 1.4.21 has been patched to detect the manipulation in the binary input stream causing the the stack overflow and raises an InputManipulationException instead. Users are advised to upgrade. Users unable to upgrade may catch the StackOverflowError in the client code calling XStream if XStream is configured to use the BinaryStreamDriver.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2024-47072?

2 open source packages ship an affected version, including com.thoughtworks.xstream:xstream.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.21 |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.21 |
| `bea-stax` | SUSE:Enterprise Storage 7.1 | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Enterprise Storage 7.1 | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 1.2.0-150200.11.3.1 |
| `bea-stax` | SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise Module for Development Tools 15 SP5 | All versions | 1.4.21-150200.3.28.1 |
| `xstream` | SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | SUSE:Manager Proxy 4.3 | All versions | 1.2.0-150200.11.3.1 |
| `bea-stax` | SUSE:Manager Server 4.3 | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | SUSE:Manager Server Module 4.3 | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | openSUSE:Leap 15.5 | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | openSUSE:Leap 15.5 | All versions | 1.4.21-150200.3.28.1 |
| `bea-stax` | openSUSE:Leap 15.6 | All versions | 1.2.0-150200.11.3.1 |
| `xstream` | openSUSE:Leap 15.6 | All versions | 1.4.21-150200.3.28.1 |
| `xstream` | openSUSE:Tumbleweed | All versions | 1.4.21-1.1 |

## How do I fix CVE-2024-47072?

Upgrade com.thoughtworks.xstream:xstream to 1.4.21 or later.

## Is CVE-2024-47072 being exploited?

There is no known exploitation of CVE-2024-47072 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47072 and fix it if it is affected.

What it is: CVE-2024-47072 is a high-severity denial of service vulnerability in x-stream xstream, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47072 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.21
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47072/ (Markdown: https://insights.sbomify.com/CVE-2024-47072/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47072
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47072
- OSV: https://osv.dev/vulnerability/CVE-2024-47072

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47072/
Summaries are generated and may contain mistakes; the official description above is the record.
