{"answers":{"affected":"2 open source packages ship an affected version, including layui. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-47075 in the wild and no public exploit code.","fix":"Upgrade layui to 2.9.17 or later.","what":"CVE-2024-47075 is a medium-severity vulnerability in layui, published on 26 Sep 2024."},"fix_prompt":"Check this codebase for CVE-2024-47075 and fix it if it is affected.\n\nWhat it is: CVE-2024-47075 is a medium-severity vulnerability in layui, published on 26 Sep 2024. \nExploitation: There is no known exploitation of CVE-2024-47075 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- layui (npm): affected all versions; fixed in 2.9.17\n- layui (npm): affected all versions; fixed in 2.9.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-47075/ (Markdown: https://insights.sbomify.com/CVE-2024-47075/index.md)","id":"CVE-2024-47075","markdown":"https://insights.sbomify.com/CVE-2024-47075/index.md","name":"CVE-2024-47075","record":{"aliases":["GHSA-j827-6rgf-9629"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"layui","vendor":"layui"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"LayUI is a native minimalist modular Web UI component library. Versions prior to 2.9.17 have a DOM Clobbering vulnerability that can lead to Cross-site Scripting (XSS) on web pages where attacker-controlled HTML elements (e.g., `img` tags with unsanitized `name` attributes) are present. Version 2.9.17 fixes this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DOM Clobbering gadgets found in layui that lead to Cross-site Scripting","id":"CVE-2024-47075","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"libcupsfilters's cfGetPrinterAttributes5 does not validate IPP attributes returned from an IPP server","id":"CVE-2024-47076"},"packages":[{"ecosystem":"npm","fixed":["2.9.17"],"introduced":["0"],"last_affected":[],"package":"layui","purl":null,"source":"GHSA-j827-6rgf-9629"},{"ecosystem":"npm","fixed":["2.9.17"],"introduced":["0"],"last_affected":[],"package":"layui","purl":"pkg:npm/layui","source":"GHSA-j827-6rgf-9629"}],"prev":{"headline":"Dataease PostgreSQL Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability","id":"CVE-2024-47074"},"products":["layui"],"published":"2024-09-26","related":[{"cvss_score":5.4,"headline":"Layui cross-site scripting (XSS) vulnerability","id":"CVE-2023-50550","kev_date_added":null,"published":"2023-12-30"},{"cvss_score":3.5,"headline":"layui HTML Attribute cross site scripting","id":"CVE-2023-3691","kev_date_added":null,"published":"2023-07-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-26","vendors":["layui"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-47075/"}