# CVE-2024-47075: DOM Clobbering gadgets found in layui that lead to Cross-site Scripting


- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Sep 2024
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-j827-6rgf-9629

## What is CVE-2024-47075?

CVE-2024-47075 is a medium-severity vulnerability in layui, published on 26 Sep 2024. 

### Official description

LayUI is a native minimalist modular Web UI component library. Versions prior to 2.9.17 have a DOM Clobbering vulnerability that can lead to Cross-site Scripting (XSS) on web pages where attacker-controlled HTML elements (e.g., `img` tags with unsanitized `name` attributes) are present. Version 2.9.17 fixes this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-47075?

2 open source packages ship an affected version, including layui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `layui` | npm | All versions | 2.9.17 |
| `layui` | npm | All versions | 2.9.17 |

Products: Layui Layui.

## How do I fix CVE-2024-47075?

Upgrade layui to 2.9.17 or later.

## Is CVE-2024-47075 being exploited?

There is no known exploitation of CVE-2024-47075 in the wild and no public exploit code.

## Other vulnerabilities in layui

- [CVE-2023-50550](https://insights.sbomify.com/CVE-2023-50550/): Layui cross-site scripting (XSS) vulnerability (medium 5.4)
- [CVE-2023-3691](https://insights.sbomify.com/CVE-2023-3691/): layui HTML Attribute cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47075 and fix it if it is affected.

What it is: CVE-2024-47075 is a medium-severity vulnerability in layui, published on 26 Sep 2024. 
Exploitation: There is no known exploitation of CVE-2024-47075 in the wild and no public exploit code.

Affected packages and fixed versions:
- layui (npm): affected all versions; fixed in 2.9.17
- layui (npm): affected all versions; fixed in 2.9.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47075/ (Markdown: https://insights.sbomify.com/CVE-2024-47075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47075
- OSV: https://osv.dev/vulnerability/CVE-2024-47075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47075/
Summaries are generated and may contain mistakes; the official description above is the record.
