# CVE-2024-47077: authentik cross-provider token validation problems

> Attackers can steal access tokens to impersonate users or access unauthorized applications across different proxy providers in authentik.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2024
- **Updated:** 27 Sep 2024
- **Also known as:** BIT-authentik-2024-47077, GHSA-8gfm-pr6x-pfh9

## What is CVE-2024-47077?

CVE-2024-47077 is a medium-severity missing authorization vulnerability in goauthentik authentik, published on 27 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

authentik is an open-source identity provider. Prior to versions 2024.8.3 and 2024.6.5, access tokens issued to one application can be stolen by that application and used to impersonate the user against any other proxy provider. Also, a user can steal an access token they were legitimately issued for one application and use it to access another application that they aren't allowed to access. Anyone who has more than one proxy provider application with different trust domains or different access control is affected. Versions 2024.8.3 and 2024.6.5 fix the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-47077?

1 open source package ship an affected version, including authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2024.6.5, 2024.8.3 |

Products: Goauthentik Authentik.

## How do I fix CVE-2024-47077?

Upgrade authentik to a fixed version for your release line: 2024.6.5 or 2024.8.3.

## Is CVE-2024-47077 being exploited?

There is no known exploitation of CVE-2024-47077 in the wild and no public exploit code.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47077 and fix it if it is affected.

What it is: CVE-2024-47077 is a medium-severity missing authorization vulnerability in goauthentik authentik, published on 27 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47077 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2024.6.5, 2024.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47077/ (Markdown: https://insights.sbomify.com/CVE-2024-47077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47077
- OSV: https://osv.dev/vulnerability/CVE-2024-47077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47077/
Summaries are generated and may contain mistakes; the official description above is the record.
