CVE-2024-47081 Requests vulnerable to .netrc credentials leak via malicious URLs
Attackers can leak .netrc credentials to third parties via malicious URLs in the Requests HTTP library, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-47081?
CVE-2024-47081 is a medium-severity vulnerability in psf requests, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Requests is a HTTP library. Due to a URL parsing issue, Requests releases prior to 2.32.4 may leak .netrc credentials to third parties for specific maliciously-crafted URLs. Users should upgrade to version 2.32.4 to receive a fix. For older versions of Requests, use of the .netrc file can be disabled with `trust_env=False` on one's Requests Session.
Weakness: CWE-522
Which versions are affected by CVE-2024-47081?
3 open source packages ship an affected version, including requests.
| Package | Affected | Fixed in |
|---|---|---|
requests PyPI | All versions | 2.32.4 |
requests PyPI | All versions | 2.32.4 |
requests PyPI | All versions | 2.32.4 |
Linux distribution packages (37)
python3-requests AlmaLinux:10 | All versions | 2.32.4-1.el10_0 |
fence-agents-all AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-amt-ws AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-apc AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-apc-snmp AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-bladecenter AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-brocade AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-cisco-mds AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-cisco-ucs AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-common AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-compute AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-drac5 AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-eaton-snmp AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-emerson AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-eps AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-heuristics-ping AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-hpblade AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-ibm-powervs AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-ibm-vpc AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-ibmblade AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-ifmib AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-ilo-moonshot AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-ilo-mp AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-ilo-ssh AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-ilo2 AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-intelmodular AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-ipdu AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-ipmilan AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-kdump AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-kubevirt AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-lpar AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-mpath AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-redfish AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-rhevm AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-rsa AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-rsb AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
fence-agents-sbd AlmaLinux:8 | All versions | 4.2.1-129.el8_10.14 |
How do I fix CVE-2024-47081?
Upgrade requests to 2.32.4 or later.
Is CVE-2024-47081 being exploited?
There is no known exploitation of CVE-2024-47081 in the wild and no public exploit code.
Sources
Also known as ALPINE-CVE-2024-47081, ALSA-2025:12519, ALSA-2025:13234, ALSA-2025:13604, ALSA-2025:14750, ALSA-2025:14999 and 61 more.