# CVE-2024-47167: SSRF in the path parameter of /queue/join in Gradio

> Attackers can force Gradio servers to make internal HTTP requests and upload malicious files via URL inputs, risking data exfiltration and server compromise.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2024
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-576c-3j53-r9jj, PYSEC-2024-215

## What is CVE-2024-47167?

CVE-2024-47167 is a medium-severity server-side request forgery vulnerability in Gradio Project Gradio, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gradio is an open-source Python package designed for quick prototyping. This vulnerability relates to **Server-Side Request Forgery (SSRF)** in the `/queue/join` endpoint. Gradio’s `async_save_url_to_cache` function allows attackers to force the Gradio server to send HTTP requests to user-controlled URLs. This could enable attackers to target internal servers or services within a local network and possibly exfiltrate data or cause unwanted internal requests. Additionally, the content from these URLs is stored locally, making it easier for attackers to upload potentially malicious files to the server. This impacts users deploying Gradio servers that use components like the Video component which involve URL fetching. Users are advised to upgrade to `gradio>=5` to address this issue.  As a workaround, users can disable or heavily restrict URL-based inputs in their Gradio applications to trusted domains only. Additionally, implementing stricter URL validation (such as allowinglist-based validation) and ensuring that local or internal network addresses cannot be requested via the `/queue/join` endpoint can help mitigate the risk of SSRF attacks.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-47167?

3 open source packages ship an affected version, including gradio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradio` | PyPI | All versions | 5.0.0 |
| `gradio` | PyPI | All versions | 5.0.0 |
| `gradio` | PyPI | All versions | 5.0.0 |

Products: Gradio Project Gradio.

## How do I fix CVE-2024-47167?

Upgrade gradio to 5.0.0 or later.

## Is CVE-2024-47167 being exploited?

There is no known exploitation of CVE-2024-47167 in the wild and no public exploit code.

Public exploit code:

- https://github.com/alexan011/CVE-2024-47167-Environment-Setup (github_poc): https://github.com/alexan011/CVE-2024-47167-Environment-Setup

## Other vulnerabilities in Gradio Project Gradio

- [CVE-2024-39236](https://insights.sbomify.com/CVE-2024-39236/): Withdrawn Advisory: Gradio was discovered to contain a code injection vulnerability via the component /gradio/component_meta.py (critical 9.8)
- [CVE-2023-6572](https://insights.sbomify.com/CVE-2023-6572/): Command Injection in gradio-app/gradio (critical 9.6)
- [CVE-2022-24770](https://insights.sbomify.com/CVE-2022-24770/): Improper Neutralization of Formula Elements in a CSV File in Gradio Flagging (high 8.8)
- [CVE-2026-49119](https://insights.sbomify.com/CVE-2026-49119/): Gradio < 6.16.0 Path Traversal via FileExplorer.preprocess() (high 8.7)
- [CVE-2025-23042](https://insights.sbomify.com/CVE-2025-23042/): Gradio Blocked Path ACL Bypass Vulnerability (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47167 and fix it if it is affected.

What it is: CVE-2024-47167 is a medium-severity server-side request forgery vulnerability in Gradio Project Gradio, published on 10 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47167 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradio (PyPI): affected all versions; fixed in 5.0.0
- gradio (PyPI): affected all versions; fixed in 5.0.0
- gradio (PyPI): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47167/ (Markdown: https://insights.sbomify.com/CVE-2024-47167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47167
- OSV: https://osv.dev/vulnerability/CVE-2024-47167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47167/
Summaries are generated and may contain mistakes; the official description above is the record.
