{"answers":{"affected":"2 open source packages ship an affected version, including agnai. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47169 exists.","fix":"Upgrade agnai to 1.0.330 or later.","what":"CVE-2024-47169 is a high-severity vulnerability in agnaistic agnai, published on 26 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-47169 and fix it if it is affected.\n\nWhat it is: CVE-2024-47169 is a high-severity vulnerability in agnaistic agnai, published on 26 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47169 exists.\n\nAffected packages and fixed versions:\n- agnai (npm): affected all versions; fixed in 1.0.330\n- agnai (npm): affected all versions; fixed in 1.0.330\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-47169/ (Markdown: https://insights.sbomify.com/CVE-2024-47169/index.md)","id":"CVE-2024-47169","markdown":"https://insights.sbomify.com/CVE-2024-47169/index.md","name":"CVE-2024-47169","record":{"aliases":["GHSA-mpch-89gm-hm83"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Agnai chat system","requires_auth":"low_privilege","summary":"Attackers can upload malicious JavaScript files to arbitrary server locations via directory traversal, leading to remote code execution and server compromise.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"agnai","vendor":"agnai"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"},{"id":"CWE-35","name":"Path Traversal: '.../...//'"}],"description":"Agnai is an artificial-intelligence-agnostic multi-user, mult-bot roleplaying chat system. A vulnerability in versions prior to 1.0.330 permits attackers to upload arbitrary files to attacker-chosen locations on the server, including JavaScript, enabling the execution of commands within those files. This issue could result in unauthorized access, full server compromise, data leakage, and other critical security threats. This does not affect `agnai.chat`, installations using S3-compatible storage, or self-hosting that is not publicly exposed. This does affect publicly hosted installs without S3-compatible storage. Version 1.0.330 fixes this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Agnai vulnerable to Remote Code Execution via JS Upload using Directory Traversal","id":"CVE-2024-47169","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"file_upload","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Agnai File Disclosure Vulnerability: JSON via Path Traversal","id":"CVE-2024-47170"},"packages":[{"ecosystem":"npm","fixed":["1.0.330"],"introduced":["0"],"last_affected":[],"package":"agnai","purl":null,"source":"GHSA-mpch-89gm-hm83"},{"ecosystem":"npm","fixed":["1.0.330"],"introduced":["0"],"last_affected":[],"package":"agnai","purl":"pkg:npm/agnai","source":"GHSA-mpch-89gm-hm83"}],"prev":{"headline":"The `enable_monitoring` flag set to `False` does not disable monitoring in Gradio","id":"CVE-2024-47168"},"products":["agnai"],"published":"2024-09-26","related":[{"cvss_score":4.3,"headline":"Agnai File Disclosure Vulnerability: JSON via Path Traversal","id":"CVE-2024-47170","kev_date_added":null,"published":"2024-09-26"},{"cvss_score":4.3,"headline":"Agnai vulnerable to Relative Path Traversal in Image Upload","id":"CVE-2024-47171","kev_date_added":null,"published":"2024-09-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-26","vendors":["agnaistic"]},"summary":"Attackers can upload malicious JavaScript files to arbitrary server locations via directory traversal, leading to remote code execution and server compromise.","url":"https://insights.sbomify.com/CVE-2024-47169/"}