# CVE-2024-47170: Agnai File Disclosure Vulnerability: JSON via Path Traversal

> Attackers can read arbitrary JSON files on the server if JSON_STORAGE is enabled, exposing sensitive configuration data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2024
- **Updated:** 12 Mar 2025
- **Also known as:** GHSA-h355-hm5h-cm8h

## What is CVE-2024-47170?

CVE-2024-47170 is a medium-severity path traversal vulnerability in agnaistic agnai, published on 26 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Agnai is an artificial-intelligence-agnostic multi-user, mult-bot roleplaying chat system. A vulnerability in versions prior to 1.0.330 permits attackers to read arbitrary JSON files at attacker-chosen locations on the server. This issue can lead to unauthorized access to sensitive information and exposure of confidential configuration files. This only affects installations with `JSON_STORAGE` enabled which is intended to local/self-hosting only. Version 1.0.330 fixes this issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-35 (Path Traversal: '.../...//')

## Which versions are affected by CVE-2024-47170?

2 open source packages ship an affected version, including agnai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `agnai` | npm | All versions | 1.0.330 |
| `agnai` | npm | All versions | 1.0.330 |

Products: Agnai Agnai.

## How do I fix CVE-2024-47170?

Upgrade agnai to 1.0.330 or later.

## Is CVE-2024-47170 being exploited?

There is no known exploitation of CVE-2024-47170 in the wild and no public exploit code.

## Other vulnerabilities in agnaistic agnai

- [CVE-2024-47169](https://insights.sbomify.com/CVE-2024-47169/): Agnai vulnerable to Remote Code Execution via JS Upload using Directory Traversal (high 8.8)
- [CVE-2024-47171](https://insights.sbomify.com/CVE-2024-47171/): Agnai vulnerable to Relative Path Traversal in Image Upload (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47170 and fix it if it is affected.

What it is: CVE-2024-47170 is a medium-severity path traversal vulnerability in agnaistic agnai, published on 26 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47170 in the wild and no public exploit code.

Affected packages and fixed versions:
- agnai (npm): affected all versions; fixed in 1.0.330
- agnai (npm): affected all versions; fixed in 1.0.330

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47170/ (Markdown: https://insights.sbomify.com/CVE-2024-47170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47170
- OSV: https://osv.dev/vulnerability/CVE-2024-47170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47170/
Summaries are generated and may contain mistakes; the official description above is the record.
