# CVE-2024-47173: Aimeos GraphQL API admin interface denial of service vulnerability in SaaS and marketplace setups

> Attackers can cause denial of service in Aimeos GraphQL admin interfaces within SaaS or marketplace setups.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2024
- **Updated:** 24 Oct 2024
- **Also known as:** GHSA-qxgx-hvg3-v92w

## What is CVE-2024-47173?

CVE-2024-47173 is a medium-severity denial of service vulnerability in aimeos ai-admin-graphql, published on 24 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Aimeos is an e-commerce framework. All SaaS and marketplace setups using the Aimeos GraphQL API admin interface version from 2024.04 up to 2024.07.1 are affected by a potential denial of service attack. Version 2024.07.2 fixes the issue.

Weakness: CWE-270 (Privilege Context Switching Error)

## Which versions are affected by CVE-2024-47173?

2 open source packages ship an affected version, including aimeos/ai-admin-graphql.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aimeos/ai-admin-graphql` | Packagist | From 2024.04.1 | 2024.07.2 |
| `aimeos/ai-admin-graphql` | Packagist | From 2024.04.1 | 2024.07.2 |

## How do I fix CVE-2024-47173?

Upgrade aimeos/ai-admin-graphql to 2024.07.2 or later.

## Is CVE-2024-47173 being exploited?

There is no known exploitation of CVE-2024-47173 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47173 and fix it if it is affected.

What it is: CVE-2024-47173 is a medium-severity denial of service vulnerability in aimeos ai-admin-graphql, published on 24 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47173 in the wild and no public exploit code.

Affected packages and fixed versions:
- aimeos/ai-admin-graphql (Packagist): affected from 2024.04.1; fixed in 2024.07.2
- aimeos/ai-admin-graphql (Packagist): affected from 2024.04.1; fixed in 2024.07.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47173/ (Markdown: https://insights.sbomify.com/CVE-2024-47173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47173
- OSV: https://osv.dev/vulnerability/CVE-2024-47173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47173/
Summaries are generated and may contain mistakes; the official description above is the record.
