# CVE-2024-47178: basic-auth-connect's callback uses time unsafe string comparison

> An attacker can exploit timing differences in string comparison to potentially recover authentication credentials from the basic-auth-connect middleware.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2024
- **Updated:** 30 Sep 2024
- **Also known as:** CLSA-2026-1773533800, GHSA-7p89-p6hx-q4fw, MINI-823v-hm46-mpxf, ROOT-APP-NPM-CVE-2024-47178

## What is CVE-2024-47178?

CVE-2024-47178 is a high-severity vulnerability in expressjs basic-auth-connect, published on 30 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

basic-auth-connect is Connect's Basic Auth middleware in its own module. basic-auth-connect < 1.1.0 uses a timing-unsafe equality comparison that can leak timing information. This issue has been fixed in basic-auth-connect 1.1.0.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2024-47178?

2 open source packages ship an affected version, including basic-auth-connect. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `basic-auth-connect` | npm | All versions | 1.1.0 |
| `basic-auth-connect` | npm | All versions | 1.1.0 |

Products: Expressjs Basic-Auth-Connect.

## How do I fix CVE-2024-47178?

Upgrade basic-auth-connect to 1.1.0 or later.

## Is CVE-2024-47178 being exploited?

There is no known exploitation of CVE-2024-47178 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47178 and fix it if it is affected.

What it is: CVE-2024-47178 is a high-severity vulnerability in expressjs basic-auth-connect, published on 30 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47178 in the wild and no public exploit code.

Affected packages and fixed versions:
- basic-auth-connect (npm): affected all versions; fixed in 1.1.0
- basic-auth-connect (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47178/ (Markdown: https://insights.sbomify.com/CVE-2024-47178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47178
- OSV: https://osv.dev/vulnerability/CVE-2024-47178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47178/
Summaries are generated and may contain mistakes; the official description above is the record.
