# CVE-2024-47183: Parse Server's custom object ID allows to acquire role privileges

> Attackers can escalate privileges to specific roles by setting custom object IDs when the allowCustomObjectId option is enabled.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2024
- **Updated:** 4 Oct 2024
- **Also known as:** BIT-parse-2024-47183, GHSA-8xq9-g7ch-35hg

## What is CVE-2024-47183?

CVE-2024-47183 is a high-severity vulnerability in Parseplatform Parse-Server, published on 4 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. If the Parse Server option allowCustomObjectId: true is set, an attacker that is allowed to create a new user can set a custom object ID for that new user that exploits the vulnerability and acquires privileges of a specific role. This vulnerability is fixed in 6.5.9 and 7.3.0.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2024-47183?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 6.5.9 |
| `parse-server` | npm | All versions | 6.5.9 |
| `parse-server` | npm | From 7.0.0 | 7.3.0 |
| `parse-server` | npm | From 7.0.0 | 7.3.0 |
| `parse` | Bitnami | All versions | 7.3.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2024-47183?

Upgrade parse-server to a fixed version for your release line: 6.5.9 or 7.3.0.

## Is CVE-2024-47183 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47183 exists.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47183 and fix it if it is affected.

What it is: CVE-2024-47183 is a high-severity vulnerability in Parseplatform Parse-Server, published on 4 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47183 exists.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 6.5.9
- parse-server (npm): affected all versions; fixed in 6.5.9
- parse-server (npm): affected from 7.0.0; fixed in 7.3.0
- parse-server (npm): affected from 7.0.0; fixed in 7.3.0
- parse (Bitnami): affected all versions; fixed in 7.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47183/ (Markdown: https://insights.sbomify.com/CVE-2024-47183/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47183
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47183
- OSV: https://osv.dev/vulnerability/CVE-2024-47183

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47183/
Summaries are generated and may contain mistakes; the official description above is the record.
