{"answers":{"affected":"4 open source packages ship an affected version, including filament/infolists and filament/tables. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-47186 in the wild and no public exploit code.","fix":"Upgrade filament/infolists to 3.2.115 or later.","what":"CVE-2024-47186 is a medium-severity cross-site scripting vulnerability in filamentphp filament, published on 27 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-47186 and fix it if it is affected.\n\nWhat it is: CVE-2024-47186 is a medium-severity cross-site scripting vulnerability in filamentphp filament, published on 27 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-47186 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- filament/infolists (Packagist): affected from 3.0.0; fixed in 3.2.115\n- filament/infolists (Packagist): affected from 3.0.0; fixed in 3.2.115\n- filament/tables (Packagist): affected from 3.0.0; fixed in 3.2.115\n- filament/tables (Packagist): affected from 3.0.0; fixed in 3.2.115\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-47186/ (Markdown: https://insights.sbomify.com/CVE-2024-47186/index.md)","id":"CVE-2024-47186","markdown":"https://insights.sbomify.com/CVE-2024-47186/index.md","name":"CVE-2024-47186","record":{"aliases":["GHSA-9h9q-qhxg-89xr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Filament Laravel components","requires_auth":"none","summary":"Attackers can inject malicious scripts via unvalidated color values in Filament components, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"filament","vendor":"filamentphp"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Filament is a collection of full-stack components for Laravel development. Versions of Filament from v3.0.0 through v3.2.114 are affected by a cross-site scripting (XSS) vulnerability. If values passed to a `ColorColumn` or `ColumnEntry` are not valid and contain a specific set of characters, applications are vulnerable to XSS attack against a user who opens a page on which a color column or entry is rendered. Filament v3.2.115 fixes this issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Filament has unvalidated ColorColumn and ColorEntry values that can be used for Cross-site Scripting","id":"CVE-2024-47186","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"Suricata datasets: missing hashtable random seed leads to potential DoS","id":"CVE-2024-47187"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.115"],"introduced":["3.0.0"],"last_affected":[],"package":"filament/infolists","purl":null,"source":"GHSA-9h9q-qhxg-89xr"},{"ecosystem":"Packagist","fixed":["3.2.115"],"introduced":["3.0.0"],"last_affected":[],"package":"filament/infolists","purl":"pkg:composer/filament/infolists","source":"GHSA-9h9q-qhxg-89xr"},{"ecosystem":"Packagist","fixed":["3.2.115"],"introduced":["3.0.0"],"last_affected":[],"package":"filament/tables","purl":null,"source":"GHSA-9h9q-qhxg-89xr"},{"ecosystem":"Packagist","fixed":["3.2.115"],"introduced":["3.0.0"],"last_affected":[],"package":"filament/tables","purl":"pkg:composer/filament/tables","source":"GHSA-9h9q-qhxg-89xr"}],"prev":{"headline":"Ampache vulnerable to Stored XSS via Democratic Playlist Name","id":"CVE-2024-47184"},"products":["filament"],"published":"2024-09-27","related":[{"cvss_score":8.1,"headline":"Filament's multi-factor authentication (app) recovery codes can be used multiple times","id":"CVE-2025-67507","kev_date_added":null,"published":"2025-12-10"},{"cvss_score":7.3,"headline":"Filament: Unvalidated Range and Values summarizer values can be used for XSS","id":"CVE-2026-33080","kev_date_added":null,"published":"2026-03-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-27","vendors":["filamentphp"]},"summary":"Attackers can inject malicious scripts via unvalidated color values in Filament components, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2024-47186/"}