# CVE-2024-47186: Filament has unvalidated ColorColumn and ColorEntry values that can be used for Cross-site Scripting

> Attackers can inject malicious scripts via unvalidated color values in Filament components, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Sep 2024
- **Updated:** 27 Sep 2024
- **Also known as:** GHSA-9h9q-qhxg-89xr

## What is CVE-2024-47186?

CVE-2024-47186 is a medium-severity cross-site scripting vulnerability in filamentphp filament, published on 27 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Filament is a collection of full-stack components for Laravel development. Versions of Filament from v3.0.0 through v3.2.114 are affected by a cross-site scripting (XSS) vulnerability. If values passed to a `ColorColumn` or `ColumnEntry` are not valid and contain a specific set of characters, applications are vulnerable to XSS attack against a user who opens a page on which a color column or entry is rendered. Filament v3.2.115 fixes this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-47186?

4 open source packages ship an affected version, including filament/infolists and filament/tables. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `filament/infolists` | Packagist | From 3.0.0 | 3.2.115 |
| `filament/infolists` | Packagist | From 3.0.0 | 3.2.115 |
| `filament/tables` | Packagist | From 3.0.0 | 3.2.115 |
| `filament/tables` | Packagist | From 3.0.0 | 3.2.115 |

Products: Filamentphp Filament.

## How do I fix CVE-2024-47186?

Upgrade filament/infolists to 3.2.115 or later.

## Is CVE-2024-47186 being exploited?

There is no known exploitation of CVE-2024-47186 in the wild and no public exploit code.

## Other vulnerabilities in filamentphp filament

- [CVE-2025-67507](https://insights.sbomify.com/CVE-2025-67507/): Filament's multi-factor authentication (app) recovery codes can be used multiple times (high 8.1)
- [CVE-2026-33080](https://insights.sbomify.com/CVE-2026-33080/): Filament: Unvalidated Range and Values summarizer values can be used for XSS (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47186 and fix it if it is affected.

What it is: CVE-2024-47186 is a medium-severity cross-site scripting vulnerability in filamentphp filament, published on 27 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-47186 in the wild and no public exploit code.

Affected packages and fixed versions:
- filament/infolists (Packagist): affected from 3.0.0; fixed in 3.2.115
- filament/infolists (Packagist): affected from 3.0.0; fixed in 3.2.115
- filament/tables (Packagist): affected from 3.0.0; fixed in 3.2.115
- filament/tables (Packagist): affected from 3.0.0; fixed in 3.2.115

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47186/ (Markdown: https://insights.sbomify.com/CVE-2024-47186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47186
- OSV: https://osv.dev/vulnerability/CVE-2024-47186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47186/
Summaries are generated and may contain mistakes; the official description above is the record.
