CVE-2024-47208 Apache OFBiz: URLs allowing remote use of Groovy expressions, leading to RCE
Attackers can execute arbitrary Groovy code remotely via crafted URLs, leading to full system compromise in Apache OFBiz.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-47208?
CVE-2024-47208 is a critical code injection vulnerability in Apache Ofbiz, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Server-Side Request Forgery (SSRF), Improper Control of Generation of Code ('Code Injection') vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: before 18.12.17.
Users are recommended to upgrade to version 18.12.17, which fixes the issue.
Which versions are affected by CVE-2024-47208?
It affects 1 product.
Products include Apache Ofbiz.
How do I fix CVE-2024-47208?
No fix has been published for CVE-2024-47208 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-47208 being exploited?
There is no known exploitation of CVE-2024-47208 in the wild and no public exploit code.
Other vulnerabilities in Apache Ofbiz
- CVE-2024-45195 Apache OFBiz Forced Browsing
- CVE-2024-32113 Apache OFBiz Path Traversal
- CVE-2024-38856 Apache OFBiz Incorrect Authorization
- CVE-2013-2250 Code injection in n/a
- CVE-2012-3506 Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.
Sources
Also known as GHSA-qxp5-vjrm-298x.