# CVE-2024-47211: OpenStack Ironic fails to verify checksums of supplied image_source URLs

> Attackers can bypass integrity checks on image sources during raw format conversion, potentially serving malicious or corrupted data to bare metal nodes.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2024
- **Updated:** 5 Nov 2024
- **Also known as:** DEBIAN-CVE-2024-47211, GHSA-8h22-6qwx-q4w9, PYSEC-2026-1468, RHSA-2025:0439, RHSA-2025:3482, UBUNTU-CVE-2024-47211

## What is CVE-2024-47211?

CVE-2024-47211 is a medium-severity vulnerability in n/a, published on 4 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In OpenStack Ironic before 21.4.4, 22.x and 23.x before 23.0.3, 23.x and 24.x before 24.1.3, and 25.x and 26.x before 26.1.0, there is a lack of checksum validation of supplied image_source URLs when configured to convert images to a raw format for streaming.

## Which versions are affected by CVE-2024-47211?

9 open source packages ship an affected version, including ironic.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ironic` | PyPI | All versions | 23.0.3, 24.1.3, 26.1.1 |
| `ironic` | PyPI | All versions to 21.4.3 | None |
| `ironic` | PyPI | All versions to 21.4.3 | None |
| `ironic` | PyPI | From 22.0.0 | 23.0.3 |
| `ironic` | PyPI | From 22.0.0 | 23.0.3 |
| `ironic` | PyPI | From 23.1.0 | 24.1.3 |
| `ironic` | PyPI | From 23.1.0 | 24.1.3 |
| `ironic` | PyPI | From 25.0.0 | 26.1.1 |
| `ironic` | PyPI | From 25.0.0 | 26.1.1 |
| `openstack-ironic` | Red Hat:openstack:17.1::el9 | All versions | 1:17.1.1-17.1.20241122190825.c31db88.el9ost |
| `openstack-ironic-api` | Red Hat:openstack:17.1::el9 | All versions | 1:17.1.1-17.1.20241122190825.c31db88.el9ost |
| `openstack-ironic-common` | Red Hat:openstack:17.1::el9 | All versions | 1:17.1.1-17.1.20241122190825.c31db88.el9ost |
| `openstack-ironic-conductor` | Red Hat:openstack:17.1::el9 | All versions | 1:17.1.1-17.1.20241122190825.c31db88.el9ost |
| `openstack-ironic` | Red Hat:openstack:18.0::el9 | All versions | 1:21.4.5-18.0.20241207142602.9213ccd.el9ost |
| `openstack-ironic-api` | Red Hat:openstack:18.0::el9 | All versions | 1:21.4.5-18.0.20241207142602.9213ccd.el9ost |
| `openstack-ironic-common` | Red Hat:openstack:18.0::el9 | All versions | 1:21.4.5-18.0.20241207142602.9213ccd.el9ost |
| `openstack-ironic-conductor` | Red Hat:openstack:18.0::el9 | All versions | 1:21.4.5-18.0.20241207142602.9213ccd.el9ost |

## How do I fix CVE-2024-47211?

Upgrade ironic to a fixed version for your release line: 23.0.3, 24.1.3 or 26.1.1.

## Is CVE-2024-47211 being exploited?

There is no known exploitation of CVE-2024-47211 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47211 and fix it if it is affected.

What it is: CVE-2024-47211 is a medium-severity vulnerability in n/a, published on 4 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47211 in the wild and no public exploit code.

Affected packages and fixed versions:
- ironic (PyPI): affected all versions; fixed in 23.0.3, 24.1.3, 26.1.1
- ironic (PyPI): affected all versions up to 21.4.3; no fix listed
- ironic (PyPI): affected all versions up to 21.4.3; no fix listed
- ironic (PyPI): affected from 22.0.0; fixed in 23.0.3
- ironic (PyPI): affected from 22.0.0; fixed in 23.0.3
- ironic (PyPI): affected from 23.1.0; fixed in 24.1.3
- ironic (PyPI): affected from 23.1.0; fixed in 24.1.3
- ironic (PyPI): affected from 25.0.0; fixed in 26.1.1
- ironic (PyPI): affected from 25.0.0; fixed in 26.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47211/ (Markdown: https://insights.sbomify.com/CVE-2024-47211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47211
- OSV: https://osv.dev/vulnerability/CVE-2024-47211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47211/
Summaries are generated and may contain mistakes; the official description above is the record.
