CVE-2024-47220 HTTP Request Smuggling in ruby webrick
Not scored
Published
Updated
Check this codebase for CVE-2024-47220 and fix it if it is affected.
What it is: CVE-2024-47220 is a vulnerability in webrick, published on 22 Sep 2024.
Exploitation: There is no known exploitation of CVE-2024-47220 in the wild and no public exploit code.
Affected packages and fixed versions:
- webrick (RubyGems): affected all versions; fixed in 1.8.2
- webrick (RubyGems): affected all versions; fixed in 1.8.2
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2024-47220/ (Markdown: https://insights.sbomify.com/CVE-2024-47220/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2024-47220?
CVE-2024-47220 is a vulnerability in webrick, published on 22 Sep 2024.
Official description
DO NOT USE THIS CVE RECORD. ConsultIDs: none. Reason: This record was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: none.
Which versions are affected by CVE-2024-47220?
2 open source packages ship an affected version, including webrick.
| Package | Affected | Fixed in |
|---|---|---|
webrick RubyGems | All versions | 1.8.2 |
webrick RubyGems | All versions | 1.8.2 |
Linux distribution packages (2)
ruby2.1 SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 2.1.9-19.9.1 |
ruby2.1 SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 2.1.9-19.9.1 |
How do I fix CVE-2024-47220?
Upgrade webrick to 1.8.2 or later.
Is CVE-2024-47220 being exploited?
There is no known exploitation of CVE-2024-47220 in the wild and no public exploit code.
Sources
Also known as GHSA-6f62-3596-g6w7, MGASA-2024-0348, OESA-2024-2226, OESA-2024-2247, ROOT-APP-RUBY-CVE-2024-47220, SUSE-SU-2024:3939-1 and 3 more.