CVE-2024-47248 Apache NimBLE: Buffer overflow in NimBLE MESH Bluetooth stack

Medium 6.3 Published Updated

A buffer overflow in Apache NimBLE allows attackers to cause memory corruption via crafted MESH messages in non-default builds.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-47248?

CVE-2024-47248 is a medium-severity memory corruption vulnerability in Apache NimBLE, published on 26 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in Apache NimBLE.

Specially crafted MESH message could result in memory corruption when non-default build configuration is used. This issue affects Apache NimBLE: through 1.7.0.

Users are recommended to upgrade to version 1.8.0, which fixes the issue.

Weakness: CWE-120

Which versions are affected by CVE-2024-47248?

It affects 1 product.

Products include Apache Nimble.

How do I fix CVE-2024-47248?

No fix has been published for CVE-2024-47248 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2024-47248 being exploited?

There is no known exploitation of CVE-2024-47248 in the wild and no public exploit code.

Sources

Also known as GHSA-f94q-ffqr-x638.

Is CVE-2024-47248 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free