CVE-2024-47249 Apache NimBLE: Lack of input sanitization leading to out-of-bound reads in multiple advertisement handler

Medium 5.0 Published Updated

A malicious Bluetooth controller can cause out-of-bound memory reads and crashes in Apache NimBLE due to improper input validation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-47249?

CVE-2024-47249 is a medium-severity memory corruption vulnerability in Apache NimBLE, published on 26 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Improper Validation of Array Index vulnerability in Apache NimBLE.

Lack of input validation for HCI events from controller could result in out-of-bound memory corruption and crash. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0.

Users are recommended to upgrade to version 1.8.0, which fixes the issue.

Weakness: CWE-129

Which versions are affected by CVE-2024-47249?

It affects 1 product.

Products include Apache Nimble.

How do I fix CVE-2024-47249?

No fix has been published for CVE-2024-47249 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2024-47249 being exploited?

There is no known exploitation of CVE-2024-47249 in the wild and no public exploit code.

Sources

Also known as GHSA-fw6g-5qw9-p3mx.

Is CVE-2024-47249 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free