CVE-2024-47258 Security feature bypass in 2N Access Commander
Attackers can intercept traffic between 2N Access Commander and edge devices due to missing certificate validation, exposing sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-47258?
CVE-2024-47258 is a high-severity vulnerability in 2N Access Commander, published on 6 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
2N Access Commander version 2.1 and prior is vulnerable in default settings to Man In The Middle attack due to not verifying certificates of 2N edge devices.
2N has currently released an updated version 3.3 of 2N Access Commander, with added Certificate Fingerprint Verification. Since version 2.2 of 2N Access Commander (released in February 2022) it is also possible to enforce TLS certificate validation.It is recommended that all customers update 2N Access Commander to the latest version and use one of two mentioned practices.
Weakness: CWE-295
Which versions are affected by CVE-2024-47258?
How do I fix CVE-2024-47258?
No fix has been published for CVE-2024-47258 yet. Limit exposure of the affected software until one is available.
Is CVE-2024-47258 being exploited?
There is no known exploitation of CVE-2024-47258 in the wild and no public exploit code.
Sources
Also known as GHSA-gcp8-45qv-x5w6.