# CVE-2024-47401: DoS via Amplified GraphQL Response in Playbooks

> An attacker can crash the Mattermost application by sending crafted requests to Playbooks, causing an amplified GraphQL response.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2024
- **Updated:** 29 Oct 2024
- **Also known as:** GHSA-762v-rq7q-ff97, GO-2024-3234

## What is CVE-2024-47401?

CVE-2024-47401 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 29 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 9.10.x <= 9.10.2, 9.11.x <= 9.11.1 and 9.5.x <= 9.5.9 fail to prevent detailed error messages from being displayed in Playbooks which allows an attacker to generate a large response and cause an amplified GraphQL response which in turn could cause the application to crash by sending a specially crafted request to Playbooks.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-47401?

6 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20240926115259-20ed58906adc |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20240926115259-20ed58906adc |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20240926115259-20ed58906adc |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2024-47401?

Upgrade github.com/mattermost/mattermost/server/v8 to 8.0.0-20240926115259-20ed58906adc or later.

## Is CVE-2024-47401 being exploited?

There is no known exploitation of CVE-2024-47401 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47401 and fix it if it is affected.

What it is: CVE-2024-47401 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 29 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-47401 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20240926115259-20ed58906adc
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20240926115259-20ed58906adc
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20240926115259-20ed58906adc
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47401/ (Markdown: https://insights.sbomify.com/CVE-2024-47401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47401
- OSV: https://osv.dev/vulnerability/CVE-2024-47401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47401/
Summaries are generated and may contain mistakes; the official description above is the record.
