# CVE-2024-4751: WP Prayer II <= 2.4.7 - Settings Update via CSRF

> Attackers can trick logged-in admins into changing WP Prayer II plugin settings via CSRF, requiring an upgrade to fix.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 Jun 2024
- **Updated:** 9 Aug 2024
- **Also known as:** GHSA-3q86-v8qf-7gw8

## What is CVE-2024-4751?

CVE-2024-4751 is a medium-severity vulnerability in Unknown WP Prayer II, published on 14 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The WP Prayer II WordPress plugin through 2.4.7 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-4751?

It affects 1 product.


Products: Goprayer Prayer.

## How do I fix CVE-2024-4751?

No fix has been published for CVE-2024-4751 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-4751 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4751 exists.

## Other vulnerabilities in Unknown WP Prayer II

- [CVE-2024-4480](https://insights.sbomify.com/CVE-2024-4480/): WP Prayer II <= 2.4.7 - Email Settings Update via CSRF (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4751 and fix it if it is affected.

What it is: CVE-2024-4751 is a medium-severity vulnerability in Unknown WP Prayer II, published on 14 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4751 exists.

Affected product: Unknown WP Prayer II. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4751/ (Markdown: https://insights.sbomify.com/CVE-2024-4751/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4751
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4751
- OSV: https://osv.dev/vulnerability/CVE-2024-4751

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4751/
Summaries are generated and may contain mistakes; the official description above is the record.
