# CVE-2024-47527: LibreNMS has a Stored XSS ('Cross-site Scripting') in librenms/includes/html/pages/device-dependencies.inc.php

> Authenticated users can inject JavaScript via device names in LibreNMS, leading to session hijacking and unauthorized actions for other users.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Oct 2024
- **Updated:** 1 Oct 2024
- **Also known as:** GHSA-rwwc-2v8q-gc9v

## What is CVE-2024-47527?

CVE-2024-47527 is a high-severity cross-site scripting vulnerability in Librenms Librenms, published on 1 Oct 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the "Device Dependencies" feature allows authenticated users to inject arbitrary JavaScript through the device name ("hostname" parameter). This vulnerability can lead to the execution of malicious code in the context of other users' sessions, potentially compromising their accounts and allowing unauthorized actions. This vulnerability is fixed in 24.9.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-47527?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 24.9.0 |
| `librenms/librenms` | Packagist | All versions | 24.9.0 |

Products: Librenms Librenms.

## How do I fix CVE-2024-47527?

Upgrade librenms/librenms to 24.9.0 or later.

## Is CVE-2024-47527 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47527 exists.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47527 and fix it if it is affected.

What it is: CVE-2024-47527 is a high-severity cross-site scripting vulnerability in Librenms Librenms, published on 1 Oct 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47527 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 24.9.0
- librenms/librenms (Packagist): affected all versions; fixed in 24.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47527/ (Markdown: https://insights.sbomify.com/CVE-2024-47527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47527
- OSV: https://osv.dev/vulnerability/CVE-2024-47527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47527/
Summaries are generated and may contain mistakes; the official description above is the record.
