# CVE-2024-47533: Cobbler allows anyone to connect to cobbler XML-RPC server with a known password and make changes

> Attackers can bypass authentication on Cobbler XML-RPC using hardcoded credentials to gain full control and modify server configurations.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2024
- **Updated:** 18 Nov 2024
- **Also known as:** GHSA-m26c-fcgh-cp6h, OESA-2025-1411, OESA-2025-1412, OESA-2025-1413, OESA-2025-1414, OESA-2025-1435, PYSEC-2026-316, openSUSE-SU-2024:0370-1, openSUSE-SU-2024:0382-1, openSUSE-SU-2024:14512-1

## What is CVE-2024-47533?

CVE-2024-47533 is a critical authentication bypass vulnerability in cobbler, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cobbler, a Linux installation server that allows for rapid setup of network installation environments, has an improper authentication vulnerability starting in version 3.0.0 and prior to versions 3.2.3 and 3.3.7. `utils.get_shared_secret()` always returns `-1`, which allows anyone to connect to cobbler XML-RPC as user `''` password `-1` and make any changes. This gives anyone with network access to a cobbler server full control of the server. Versions 3.2.3 and 3.3.7 fix the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-47533?

5 open source packages ship an affected version, including cobbler.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cobbler` | PyPI | From 3.0.0 | 3.2.3, 3.3.7 |
| `cobbler` | PyPI | From 3.0.0 | 3.2.3 |
| `cobbler` | PyPI | From 3.0.0 | 3.2.3 |
| `cobbler` | PyPI | From 3.3.0 | 3.3.7 |
| `cobbler` | PyPI | From 3.3.0 | 3.3.7 |
| `cobbler` | SUSE:Package Hub 15 SP5 | All versions | 3.3.7-bp155.2.3.2 |
| `cobbler` | SUSE:Package Hub 15 SP6 | All versions | 3.3.7-bp156.2.6.1 |
| `cobbler` | openSUSE:Leap 15.5 | All versions | 3.3.7-bp155.2.3.2 |
| `cobbler` | openSUSE:Leap 15.6 | All versions | 3.3.7-bp156.2.6.1 |
| `cobbler` | openSUSE:Tumbleweed | All versions | 3.3.7-1.1 |

## How do I fix CVE-2024-47533?

Upgrade cobbler to a fixed version for your release line: 3.2.3 or 3.3.7.

## Is CVE-2024-47533 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47533 exists.

Public exploit code:

- CVE-2024-47533 is a critical authentication bypass vulnerability in Cobbler (versions 3.0.0 to before 3.2.3 and 3.3.7) allowing unauthenticated remote code execution via the XMLRPC interface. (github_poc): https://github.com/dollarboysushil/CVE-2024-47533-Cobbler-XMLRPC-Authentication-Bypass-RCE-Exploit-POC
-  CVE-2024-47533: Cobbler Authentication Bypass & Code Execution (github_poc): https://github.com/baph00met/CVE-2024-47533
- https://github.com/00xCanelo/CVE-2024-47533-PoC (github_poc): https://github.com/00xCanelo/CVE-2024-47533-PoC
- PoC of CVE-2025-47533 Clobber RCE (github_poc): https://github.com/zs1n/CVE-2024-47533
- https://github.com/okkotsu1/CVE-2024-47533 (github_poc): https://github.com/okkotsu1/CVE-2024-47533
- Cobbler 'XML-RPC' - Authentication Bypass (nuclei): http/cves/2024/CVE-2024-47533.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-47533 and fix it if it is affected.

What it is: CVE-2024-47533 is a critical authentication bypass vulnerability in cobbler, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-47533 exists.

Affected packages and fixed versions:
- cobbler (PyPI): affected from 3.0.0; fixed in 3.2.3, 3.3.7
- cobbler (PyPI): affected from 3.0.0; fixed in 3.2.3
- cobbler (PyPI): affected from 3.0.0; fixed in 3.2.3
- cobbler (PyPI): affected from 3.3.0; fixed in 3.3.7
- cobbler (PyPI): affected from 3.3.0; fixed in 3.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-47533/ (Markdown: https://insights.sbomify.com/CVE-2024-47533/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-47533
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-47533
- OSV: https://osv.dev/vulnerability/CVE-2024-47533

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-47533/
Summaries are generated and may contain mistakes; the official description above is the record.
